[Owncloud] Files_Sharing Update

Arthur Schiwon blizzz at owncloud.com
Tue Sep 25 10:35:10 UTC 2012


i spent now some time to fix my trouble with the upgrade from 4.0.7 to 4.5 with 
Files_Sharing. There were more issues for me than initially found.

First,  I got errors because OC_FileSystem was not initialized, then the user 
backends where not available. This is fixed with 
15e02726d76555ea9eb2dd59a88d2310bcd9b08c I hope it makes sense.

Then the old reshares made the update script fail. I fixed it with 
80fde2d8d1a0f70a62416241a9bf9c8e4f0ac489. Doing so, the Reshares will be 
recreated. Again I hope that makes sense. 

Now, I was hit by the error that a file has been shared twice with a public 
link, this will make the update script also break. Since it is more or less OK 
now (the Shared link will be done) I am fine with a notice about that. However, 
an exception is thrown on error, i.e. white page with error messages for the 
user and no finished Update. For me I solved it by replacing the Exception with 
the OCP\Util::writeLog.
I hesitated to push it to master, yet.

The last thing is that the old table is not deleted (it is prepared, though, i  
uncommented it for me). As long as the table persists and the entries are in 
the new table, new collission will occur. As long as the Exception is thrown, 
it will make things worse. 
I pledge for using writeLog and removing (or at least renaming) of the table. 
I leave this to Michael.

And last thing: the old public links do not work anymore. I have no idea how 
to fix it.


More information about the Owncloud mailing list