[Owncloud] Fwd: ownCloud 4.5 beta 4

Bjoern Schiessle schiessle at owncloud.com
Fri Sep 21 15:09:58 UTC 2012

On Fri, 21 Sep 2012 15:09:15 +0100 Duarte Velez Grilo wrote:
> Ok, so I tried giving broader rights, but that still didn't do it. I
> then googled more about curl and certificates, trying that command on
> the cli with some other variations, and eventually decided to look at
> the rootcerts.crt file, because it was the only thing left and things
> did point to that. I noticed that the "END CERTIFICATE" and the next
> "BEGIN CERTIFICATE" (for the second file) were on the same line. This
> indeed looked wrong, so I just added a line break, separating the two.
> Lo and behold, the error is no more!
> So, the bug is when importing the certificates: the resulting
> rootcerts.crt file should have the certificates appended with a line
> break after "-----END CERTIFICATE-----". Unfortunately, I don't know
> where this is done, but I'm sure someone can take this and push a fix?

All certificates I tried had a line break after the last line,
therefore I never had a problem here. I now added a new line after every
certificate since it seems that a possible extra new lines doesn't hurt.

> I then removed the webdav configuration and re-added it, just to make
> sure. The mounted folder still appears empty, but at least there
> aren't any errors.

Same for me. But this also happens without SSL so this is not related
to the SSL handling. Maybe box.com needs a special path to the files?
But on the command line and in the browser it works just fine.

Do you (or anybody else) have other webdav sources for testing? Since I
only have a second ownCloud to mount over webdav. It would be good if we
could test the webdav mount with other sources too.


Björn Schießle <schiessle at owncloud.com>
Software Developer
ownCloud GmbH

Your Data, Your Cloud, Your Way!

ownCloud GmbH, GF: Markus Rex, Holger Dyroff
Schloßäckerstrasse 26a, 90443 Nürnberg, HRB 28050 (AG Nürnberg)

More information about the Owncloud mailing list