[Owncloud] OC - no input file specified APACHE

Gabor Bukovszki gabor at bukovszki.hu
Mon Sep 17 20:25:47 UTC 2012

Good Day to you all,

After upgrading from OC2 to the latest and greatest OC 4.0.6 Web DAV
(and Cal DAV, and iCAL, basically anything which goes through
remote.php) has stopped functioning. Searching trough the forums and
the bug reports, I have learned that NGINX has problems with OC which
can be worked around. Unluckily I have Apache installed.

The details:

It's a shared hosting at godaddy, Linux (Cent OS?) with Apache and PHP
5.3, My SQL DB, Owncloud 4.0.6 fresh install and also an upgraded OC2:
opening the page http://<server>/remote.php/webdav/ is throwing

No input file specified.

DAVFS2 mounting says following:

/sbin/mount.davfs: Mounting failed. 404 Not Found

Using the old link: http://<server>/files/webdav.php in a web browser
I am asked to provide my user and pass, as I do it I also see my
folders (without icons however), when I try to open a folder I get "No
input file specified." Trying to mount with davfs I only got a 404.

Nothing customized by the new install.

I have also tried to file a bug but no response. I tried to search me
dead with google, obviously all answers are for ngnix.

Could at least someone give me a hint where should I try to debug this
issue? (I am not new to linux, but had nothing to do with web/php).

Many Thanks,
Gabor Bukovszki

More information about the Owncloud mailing list