[Owncloud] Sync client for PowerPC?

loic.balla at free.fr loic.balla at free.fr
Tue Sep 4 18:57:11 UTC 2012

Thank you for the link.
I've installed a lot of packages and the cmake command seems to have worked. But there is problem with my iniparser when I run make (although it was found during cmake). Here is a copy of my terminal, hope it helps - and someone can help me.


karkaf at karkaf:~/owncloud/buildcsync$  cmake -DCMAKE_BUILD_TYPE="Debug" -DLOG_TO_CALLBACK=ON -DWITH_LOG4C=OFF ../csync
-- The C compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Performing Test WITH_FPIC
-- Performing Test WITH_FPIC - Success
-- Performing Test WITH_STACK_PROTECTOR - Success
-- Performing Test WITH_FORTIFY_SOURCE
-- Performing Test WITH_FORTIFY_SOURCE - Success
-- Found Log4C: /usr/lib/liblog4c.so 
-- Looking for clock_gettime in rt
-- Looking for clock_gettime in rt - found
-- Looking for dlopen in dl
-- Looking for dlopen in dl - found
-- Looking for asprintf
-- Looking for asprintf - found
-- Looking for fnmatch
-- Looking for fnmatch - found
-- Looking for strerror_r
-- Looking for strerror_r - found
-- Looking for utimes
-- Looking for utimes - found
-- Looking for lstat
-- Looking for lstat - found
-- checking for module 'sqlite3'
--   found sqlite3, version 3.7.9
-- Found SQLite3: /usr/lib/powerpc-linux-gnu/libsqlite3.so
-- Found Iniparser: /usr/lib/libiniparser.a 
-- checking for module 'openssl'
--   found openssl, version 1.0.1
-- Found OpenSSL: /usr/lib/powerpc-linux-gnu/libssl.so;/usr/lib/powerpc-linux-gnu/libcrypto.so (found version "1..1")
-- Found Libsmbclient: /usr/lib/powerpc-linux-gnu/libsmbclient.so
-- Found LibSSH: /usr/lib/powerpc-linux-gnu/libssh.so (Required is at least version "0.4.0")
-- checking for module 'neon'
--   found neon, version 0.29.6
-- Found Neon: /usr/lib/libneon.so 
-- Could NOT find Doxygen (missing:  DOXYGEN_EXECUTABLE) 
-- checking for module 'check'
--   package 'check' not found
-- Could NOT find Check (missing:  CHECK_LIBRARIES CHECK_INCLUDE_DIRS) 
-- Configuring done
-- Generating done
-- Build files have been written to: /home/karkaf/owncloud/buildcsync
karkaf at karkaf:~/owncloud/buildcsync$ make
Scanning dependencies of target cstdlib
[  3%] Building C object src/std/CMakeFiles/cstdlib.dir/c_alloc.c.o
[  6%] Building C object src/std/CMakeFiles/cstdlib.dir/c_dir.c.o
[ 10%] Building C object src/std/CMakeFiles/cstdlib.dir/c_file.c.o
[ 13%] Building C object src/std/CMakeFiles/cstdlib.dir/c_list.c.o
[ 17%] Building C object src/std/CMakeFiles/cstdlib.dir/c_path.c.o
[ 20%] Building C object src/std/CMakeFiles/cstdlib.dir/c_rbtree.c.o
[ 24%] Building C object src/std/CMakeFiles/cstdlib.dir/c_string.c.o
[ 27%] Building C object src/std/CMakeFiles/cstdlib.dir/c_time.c.o
Linking C static library libcstdlib.a
[ 27%] Built target cstdlib
Scanning dependencies of target csync
[ 31%] Building C object src/CMakeFiles/csync.dir/csync.c.o
/home/karkaf/owncloud/csync/src/csync.c: In function ‘csync_log_cb’:
/home/karkaf/owncloud/csync/src/csync.c:979:3: attention : function might be possible candidate for ‘gnu_printf’ format attribute [-Wmissing-format-attribute]
/home/karkaf/owncloud/csync/src/csync.c:979:3: attention : function might be possible candidate for ‘gnu_printf’ format attribute [-Wmissing-format-attribute]
[ 34%] Building C object src/CMakeFiles/csync.dir/csync_config.c.o
[ 37%] Building C object src/CMakeFiles/csync.dir/csync_exclude.c.o
[ 41%] Building C object src/CMakeFiles/csync.dir/csync_statedb.c.o
[ 44%] Building C object src/CMakeFiles/csync.dir/csync_time.c.o
[ 48%] Building C object src/CMakeFiles/csync.dir/csync_util.c.o
[ 51%] Building C object src/CMakeFiles/csync.dir/csync_misc.c.o
[ 55%] Building C object src/CMakeFiles/csync.dir/csync_update.c.o
[ 58%] Building C object src/CMakeFiles/csync.dir/csync_reconcile.c.o
[ 62%] Building C object src/CMakeFiles/csync.dir/csync_propagate.c.o
[ 65%] Building C object src/CMakeFiles/csync.dir/vio/csync_vio.c.o
[ 68%] Building C object src/CMakeFiles/csync.dir/vio/csync_vio_handle.c.o
[ 72%] Building C object src/CMakeFiles/csync.dir/vio/csync_vio_file_stat.c.o
[ 75%] Building C object src/CMakeFiles/csync.dir/vio/csync_vio_local.c.o
[ 79%] Building C object src/CMakeFiles/csync.dir/csync_lock.c.o
Linking C shared library libcsync.so
/usr/bin/ld: skipping incompatible /usr/lib/gcc/powerpc-linux-gnu/4.6/../../../../lib/libiniparser.a when searching for -liniparser
/usr/bin/ld: skipping incompatible /usr/lib/../lib/libiniparser.a when searching for -liniparser
/usr/bin/ld: skipping incompatible /usr/lib/gcc/powerpc-linux-gnu/4.6/../../../libiniparser.a when searching for -liniparser
/usr/bin/ld: skipping incompatible /usr/lib/libiniparser.a when searching for -liniparser
/usr/bin/ld: cannot find -liniparser
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [src/libcsync.so.0.1.8] Erreur 1
make[1]: *** [src/CMakeFiles/csync.dir/all] Erreur 2
make: *** [all] Erreur 2
karkaf at karkaf:~/owncloud/buildcsync$ 

----- Mail original -----
De: "Thomas Müller" <thomas.mueller at tmit.eu>
À: "loic balla" <loic.balla at free.fr>, owncloud at kde.org
Envoyé: Mardi 4 Septembre 2012 16:29:00
Objet: Re: [Owncloud] Sync client for PowerPC?

Am Dienstag, dem 04.09.2012 um 16:20 schrieb loic.balla at free.fr:
> Hello,
> I'd like to use owncloud but my main computer is an old Apple PowerBook G4, i.e. with PowerPc processor. It is running Lunbuntu 12.04 PPC. Is there a way to install owncloud-client on this system? (I've never compiled anything.)

You can find building instructions here:

Feel free to post further questions to this list.

Take care,

> Thank you,
> karkaf
> _______________________________________________
> Owncloud mailing list
> Owncloud at kde.org
> https://mail.kde.org/mailman/listinfo/owncloud

More information about the Owncloud mailing list