D21730: Pass gridLayout pointer to createStyleWidget
Simone Gaiarin
noreply at phabricator.kde.org
Mon Jun 10 17:50:26 BST 2019
simgunz created this revision.
Herald added a project: Okular.
Herald added a subscriber: okular-devel.
simgunz requested review of this revision.
REVISION SUMMARY
Fix design of text annotation tools
Fix layout of freehand tool
Fix layout of highlighter
Fix layout of geometrical shape
Fix layout of straight line and polygon
1. Conflicts:
2. ui/annotationwidgets.cpp
Position spacer at the bottom of the grid layout
Simplify code
1. Conflicts:
2. ui/annotationwidgets.cpp
Fix layout of stamp
Fix line endings
Fix font capitalization
Remove unuseful return
Add icon label
Fix indentation
Fix layout of caret annotation
Remove unused code
Fix layout of file attachment
Rename layout > gridLayout for clarity
Make row variable constant
Set buddy
Mark variable unused
Fix layout of extraWidget of FileAttachment
Fix layout of General Info
Use form layout instead of grid layout
Set label alignment and field growth policy
Resort code of line annotation
Fix wrong widget set as parent
Move line termination styles before leaders style
Align combobox to top
Fix label buddy not working of PixmapPreviewSelector
Fix keyboard shortcut of Author conflicts with Add
Same order of Size and Fill color for GeomShape and Polygon
Make annotation type the first element
Add color button and opacity spin manually in each annotation
This allows to add each row in order without the need to insert at position 0
the row with the "Type" for Highlighter and GeomAnnotation. Moreover it is not
possible to insert spacer items at a given row with addItem, so we cannot put a
space after the "Type" row. It also removes the need of the custom methods
hasColorButton and hasOpacityBox
Add vertical space to separate groups of settings
Add opacity spin to file attachment annotation
Rename "Size" to "Width"
Set better accelerators
Change string that inform the user about how Identity info are used
Remove only-for-pdf tooltips
Set accelerator explicitly
Set of letter 't' because 'a' and 'u' are used for Add and Move Up in widgetconfigurationtoolsbase.cpp which will appear in the same UI
REPOSITORY
R223 Okular
BRANCH
fix-annot-config-dialog
REVISION DETAIL
https://phabricator.kde.org/D21730
AFFECTED FILES
conf/dlgannotationsbase.ui
ui/annotationpropertiesdialog.cpp
ui/annotationwidgets.cpp
ui/annotationwidgets.h
To: simgunz
Cc: okular-devel, joaonetto, tfella, ngraham, darcyshen, aacid
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/okular-devel/attachments/20190610/df4d3a8e/attachment.html>
More information about the Okular-devel
mailing list