[Okular-devel] [Bug 161759] print pdf produces no output, also print to file broken

S Clark smc+kdebugs at dogphilosophy.net
Mon May 19 22:56:11 CEST 2008

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

------- Additional Comments From smc+kdebugs dogphilosophy net  2008-05-19 22:56 -------
I THINK this may be the same issue (still occurring in Okular 0.6.3/KDE 4.0.4) that I came here to report.

If it is, what I have been seeing is that Okular will not print the LAST page of a pdf (in which case, one-page PDF's don't print at all).  Print Preview seems to work normally, and SOMETHING is getting sent as a print job (I can see the printer  is receiving data, but it evidently never gets anything that compels it to spit out a page - it just reaches a "job is done" stage without printing anything.)  For multi-page pdf's, all but the last page seem to print okay (at least as of last time I tried it, in the Okular shipped in KDE 4.0.3)

Same pdf's print fine with Adobe's acrobat reader.  If I run a non-printing pdf through pdf2ps first, the resulting ps will print from Okular.

More information about the Okular-devel mailing list