[Nepomuk] Review Request 110317: kinotify: Optimize the filterWatch process

Vishesh Handa me at vhanda.in
Sun May 5 11:26:37 UTC 2013


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/110317/
-----------------------------------------------------------

Review request for Nepomuk, Àlex Fiestas and Simeon Bird.


Description
-------

    kinotify: Optimize the filterWatch process
    
    The FilterWatch is used to to not add watches to everything.
    Specifically we do not add watches to names in the exclude list. Also
    we only monitor for creation and modification events in the include
    folders.
    
    FileIndexerConfig::shouldFileBeIndexed and shouldFolderBeIndexed have a
    lot of duplicate code internally. They both use the expensive RegExp
    cache.
    
    It's better if we only use the RegExp cache once.


Diffs
-----

  services/fileindexer/fileindexerconfig.h 9d2d890 
  services/fileindexer/fileindexerconfig.cpp b09c915 
  services/filewatch/nepomukfilewatch.cpp fbbf3db 

Diff: http://git.reviewboard.kde.org/r/110317/diff/


Testing
-------

It's faster


Thanks,

Vishesh Handa

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/nepomuk/attachments/20130505/bfc4286b/attachment.html>


More information about the Nepomuk mailing list