[Nepomuk] Review Request 108811: Change dbus interface to the FileIndexer for status messages

Jörg Ehrichs joerg.ehrichs at gmx.de
Wed Feb 6 16:13:48 UTC 2013


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/108811/
-----------------------------------------------------------

Review request for Nepomuk and Vishesh Handa.


Description
-------

To have a unified dbus interface this patch adds the signal:
* statusMessage(int, string)
and the method:
* statusMessage
    
To expose the current state of the fileindexer via dbus.
This change results in the same dbus signal/slot that are used by
akonadi_nepomuk and the FileWatcher.
    
The integers are defined as
status 0: idle/suspended
status 1: working (processing/searching for files to process)
status 2: cleaning

Therefore the following method s are marked deprecated:
* userStatusString - bad naming, same as statusMessage
* simpleUserStatusString - not used/returns the same as userStatusString


Diffs
-----

  interfaces/org.kde.nepomuk.FileIndexer.xml 752604b 
  services/fileindexer/fileindexer.h afe78d7 
  services/fileindexer/fileindexer.cpp 3ddc073 
  services/fileindexer/indexscheduler.h d53e7c9 
  services/fileindexer/indexscheduler.cpp ef848e2 

Diff: http://git.reviewboard.kde.org/r/108811/diff/


Testing
-------

* Connected to the status signal via qdbusviewer
* moved files around/added new folders for the indexing.
* output shows current operation + url


Thanks,

Jörg Ehrichs

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/nepomuk/attachments/20130206/50a56497/attachment.html>


More information about the Nepomuk mailing list