[Nepomuk] Review Request: Implementing Queue in Writebackservice

Sebastian Trueg sebastian at trueg.de
Fri Aug 5 16:28:19 UTC 2011


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/102225/#review5413
-----------------------------------------------------------



nepomuk/services/writeback/service/writebackservice.h
<http://git.reviewboard.kde.org/r/102225/#comment4877>

    This is not public.



nepomuk/services/writeback/service/writebackservice.h
<http://git.reviewboard.kde.org/r/102225/#comment4878>

    I would recommend to call it something like m_lastJob or m_currentJob.



nepomuk/services/writeback/service/writebackservice.h
<http://git.reviewboard.kde.org/r/102225/#comment4879>

    spelling: slotQueue.
    Actually better call it queueResourceForWriteback. It is always good to be a bit more verbose.



nepomuk/services/writeback/service/writebackservice.cpp
<http://git.reviewboard.kde.org/r/102225/#comment4880>

    This is wrong. You do not connect to a job before creating it.
    What you need to do is to simply enqueue the resource and then call the method that gets the next resource from the queue if no job is running, ie. if m_job is 0.



nepomuk/services/writeback/service/writebackservice.cpp
<http://git.reviewboard.kde.org/r/102225/#comment4881>

    Is this ever called now?



nepomuk/services/writeback/service/writebackservice.cpp
<http://git.reviewboard.kde.org/r/102225/#comment4882>

    Add the test for the job first. And then in the slot connected to the job's result signal call this method again.


- Sebastian


On Aug. 5, 2011, 3:48 p.m., Smit Shah wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/102225/
> -----------------------------------------------------------
> 
> (Updated Aug. 5, 2011, 3:48 p.m.)
> 
> 
> Review request for Nepomuk.
> 
> 
> Summary
> -------
> 
> I have been bit busy with traveling to berlin for DS , so i am posting the review request bit late , this one is for the queue in writebackservice and i will soon post the review request for passing kdelistservice.
> 
> 
> Diffs
> -----
> 
>   nepomuk/services/writeback/service/writebackservice.h db6e83a 
>   nepomuk/services/writeback/service/writebackservice.cpp 673aa59 
> 
> Diff: http://git.reviewboard.kde.org/r/102225/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Smit
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/nepomuk/attachments/20110805/9641489f/attachment.html>


More information about the Nepomuk mailing list