Merging the android plugin to Qt Creator
BogDan
bog_dan_ro at yahoo.com
Fri Jul 22 21:02:12 CEST 2011
Hi,
I've created another branch "mr-stagging" for this job.
[..]
>b) License
>Some files currently have no license header at all
Now all .cpp and .h files from android plugin folder should have license header completed.
[..]
>0001-Remove-wrong-merge-resolution.patch
>0002-Remove-accidentally-added-.commit.template.patch
>0003-Remove-unecessary-whitespace-changes.patch
>0004-Unecessary-change-to-import-code.patch
>0006-Reformat-deployment.pri-to-be-more-readeable.patch
>0007-Bump-stub-version-of-template.patch
>0008-Remove-settign-of-ANDROID_NDK_HOST-from-necessitas.b.patch
Pushed.
>0005-Simplfy-template-code.patch
Not pushed, without setBaseUrl thing, qml engine will add file:// in front of
the file and it will not work with current android assets implementation
which need a file patch to start with a "/" or directly with its name.
[..]
>
>f) mingw/*
>Those files need to be removed from the MR for hopefully obvious reasons.
>
>g) macdeployqt/*
>============= TODO look at the patches
>There is unfourtanetly no maintainer for macdeployqt, but the patches should
>be made against the macdeployqt in qt.
>
I've remove them from QtCreator's "mr-stagging" branch, Ray please move this file to ministro repo.
>h) Changes in src/tools/qpatch
>After a quick discussion at the office we removed src/tools/qpatch completely
>from master since it is neither used by the stand alone creator packages nor
>by the sdk and is known to be buggy.
>I'd recommend instead of patching and using qpatch to use the facilities in
>the QtSDK found in installer-framework/installerbuilder/libinstaller/qtpatch
>and installerbuilder/libinstaller/qtpatchoperation.cpp and then backing out
>the changes to qpatch
>
Because we still need it, I'll move it to ministro repo.
>i) build.sh
>We don't want that as part of the creator repository. As far as we are
>concerned building creator should be done in a normal cmd shell on windows and
>not in a msys shell.
Removed.
>
>j) bin/necessitas and bin/necessitas.bat
>The setting of ANDROID_NDK_HOST seemed to be a left over from before setting
>it in androidtoolchain.cpp, so I removed it, see attached patch.
>We used to have a similar LD_LIBRARY_PATH setting script on linux but after
>some internal discussions we removed it. On windows
>
Can you share with use your secret ?
>k) Settings Path and Renaming to Necessitas
>We think if we merge the android plugin into creator, then there is no point
>in renaming Qt Creator and no point in using a different settings path. The sdk
>team also wants to produce "one" sdk that can install components from different
>providers.
Great, agreed !
>If you do want to have a different name/settings path, then there are quite a
>few places which need to be fixed and the default should be "Qt Creator" not
>"Necessitas Qt Creator"
>
We'll keep them in our "private" branch to shipour own SDK installer. I choose
to make those changes because I didn't want to pollute official QtCreaor settings :)
[..]
>
>p) debugger plugin
>The debbuger plugin has quite a few changes, some of them seem to be hacks.
>Also I'm not that well versed in the debugger plugins code, though I discussed
>a earlier diff with the debugger maintainer (Andre).
>I'm somewhat confussed whether you are using the python dumpers, or not.
We are using python dumpers !
>So, the changes:
>Adding "arm-linux-androideabi" to gnuTargets: fine
>
>soLibSearchPath: in general looks fine, andre mentioned some details he wanted
>to see fixed
>
Which one ?
>
>Always offering all toolchains in DebuggerToolChainComboBox::init
>The commit message already classifies that as a hack, I just don't understand
>why it was needed. The check for hostAbi.os() == abi.os() should be true for
>msys toolchains too. Or is .os() broken for msys toolchains?
>
Ray, any comments ?
>
>Disabling setting PYTHONPATH. Why is that needed? Note that the code that is
>disabled was rewritten a lot since you disabled it.
>
We choose to "hardcode" PYTHONPATH into gdb, so gdb doesn't need any PYTHONPATH evn variable set.
>
>q) abi.h abi.cpp
>The change looks good, but can't be merged without the rest of the android
>plugin.
>
>r) templates/qtquickapp/*
>The changes looked almost okay. I didn't understand the setBaseUrl() change,
>nor can I see how that makes sense. I reformatted some of the code for better
>readability and added a bumping of the template version. (Projects with prior
>template versions are automatically updated then.) See the attached patches.
Using setBaseUrl qml will not add "file://" in front of your url.
[..]
>
>u) Settings SystemScope to UserScope
>Quite a few settings (if not all) are using the UserScope instead of the
>SystemScope. Why is that needed?
>
Because SystemScope is not user writable (if you'll install the SDK using "sudo" that file can't be written by a normal user), so we choose to move everything to user's home, if is not correct we'll revert that change.
>I might have missed a few changes here and there.
>
>I'm looking forward to working on that. :)
>
>daniel
>
Thank you for your time !
Cheers,
BogDan.
More information about the Necessitas-devel
mailing list