[Marble-devel] Re: marble make install step fails on MS Windows (using mingw)

Bernhard Beschow bbeschow at cs.tu-berlin.de
Fri Apr 1 21:57:44 CEST 2011

Hi Ákos,

> > Have you tried to run "make install" as administrator? I figure this
> > is necessary for Vista and Win7.
> another list member, Siddharth Srivastava also pointed this out.

Yep, we had the same idea :)

> indeed,
> if I run it as admin, it installs fine (even though the installation
> directory is _not_ protected in any way - strange)
> but, now there is only one problem: any app compiled with
> libmarblewidget.dll
> will only work it is started from the CMAKE_INSTALL_PREFIX directory I
> specified at installation time. This is true for marble.exe compiled,
> but also for any (very simple) sample application using libmarblewidget.dll
> if any of these is started from another directory, then the effect is
> that the app starts, but the window displaying the 3D map it pitch
> black. mouse clicks bring up the popup menus as expected.
> do you have an idea what is going wrong? are some paths hard-coded into
> the library that have to be relative to the applications directory?
> I haven't seen this issue on either Linux or Mac..

Hmm, it looks like that under Windows, the data path is by default relative to the application directory (see MarbleDirs.cpp and the INSTALL file for details). You can pass -DMARBLE_DATA_PATH="hardcoded/path/to/data" to cmake for hardcoding an absolute (or relative) data path in the marble library. HTH


More information about the Marble-devel mailing list