[Marble-devel] Routing in marble

Dennis Nienhüser earthwings at gentoo.org
Sat May 1 23:19:55 CEST 2010

Hi Arnd,

thanks for the feedback, appreciated :-)

> - Initially one now has two Mouse-Pointer Icons, but no A and B
>   anymore. Somehow I found the A and B a good indication.
Right, I changed it.

> - Also later on,  I miss the pointer next to the label a bit,
>   as it easily allowed to start from a new place (which might
>   be "far" away from the original A, i.e. further away than
>   would be easily possible by dragging the original A).
The remove button is now always visible. Clicking remove and then the A 
/ B icon now let's you quickly choose a different destination.

> - when the Mouse-Pointer Icon is selected,
>   zooming in and out with the middle-mouse button pressed
>   and moving up/down is not possible.
Fixed, also the context menu

> - For path segments which go back-and-forth (eg a dead-end),
>   there is no right-mouse menu and also no possibility
>   to add a point. I think it should be possible to also drag
>   a point away from this line. One possibility which seems
>   reasonable to me is that it should be added in the
>   segment which is further away from the start
Found that nasty bug :)

> - when clicking on one of the "rtept" a pop-up window
>   displays the instruction ("turn left/right" etc."
>   at that point - very nice. But how can one get rid of
>   that window again (I tried to click on the point again or
>   within the window)?
It toggles now, i.e. clicking on a selected item deselects it

> - dragging of these points to a different place should be possible
>   as well.
Works now, but a distance of 10 pixel must be exceeded to avoid 
confusion with clicks. I also changed that for waypoints to have it 

> - The most crucial point to me is the one mentioned in one of my
>   previous mails  which we already discussed a bit on the IRC:
>      Imagine a connection A-B-C which geometrically leads
>      to something like a half-circle.
>      Now I would like to add an additional point between A and B,
>      by dragging via the mouse. If this additional point
>      is placed closer to the connection between B-C
>      than the one between A-B
>      one gets (in terms of the old A, B, C): A-B-Newpoint-C.
>      However, I would have expected A-Newpoint-B-C,
>      i.e. the new point should be inserted in the list of points
>      between A and B  and not between the geometrically closest points.
>      ((Side remark: If one thinks of adding a new point somewhere
>      using a mouse-click, the current approach seems correct,
>      but not for modifying a segment between two points, at least IMO)).
>   To solve this, one somehow has to figure out from which segment
>   the point was dragged away. Then the new via point just has to be
>   inserted in between these two elements.
>   One approach to find the place in the list of via-points could be
>   as follows:
>   a) Determine the corresponding closest line segment
>      along the waypoints.
>      (Here the distance between the point and all line segments
>      has to be used, as for sharp bends of the route wrong
>      associations could happen).
>   b) Then one has to find the two closest via-points along the route.
>      You pointed out that waypoints and via points are stored
>      in two independent lists. So for each via-point one could
>      attach the corresponding label to the closest point of
>      the closest route segment (sorry, sounds complicated,
>      but this seems necessary to get the right association ... ;-).
>      With this preparation, one just has to go backward in the list of
>      waypoints from the line segment found in a) to find the
>      previous via-point and forward to find the next via-point.
I hope to get that done in time for the next release.

> - Exporting to a gpx file seems to work fine, though for some reason
>   it takes quite a while until the "Export Route" dialogue
>   comes up.
>   On the konsole I see
>     kdeinit4: Got EXEC_NEW 'kio_trash' from launcher.
>     kdeinit4: preparing to launch
>     kio_trash(25952) TrashImpl::init: initialization OK, home trash 
> dir: "/home/aba/.local/share/Trash"
>     kio_trash(25952) TrashProtocol::listDir: listdir:  KUrl("trash:/")
>     kio_trash(25952) TrashImpl::infoForFile: 0   "IMG_62991.JPG"
>   and many more lines like the last one.
Works fine here, possibly just some initial delay. The button 
immediately fires up the standard Qt dialog for saving files, can't go 
much wrong on the marble side.

> - Concerning the exported file:
>   Trying to display it using prune, I get
>   "Error reading file: Invalid byte 2 of a 2-byte UTF-8 sequence"
>   The culprits are rtept entries with \"a, \"o, \ss etc.
Fixed, now proper UTF8.

> - Minor point: For the resulting file, one gets a line
>  "</trkseg></trk><rte>", where a line break after the </trk>  would
>   be nice.
True, also indenting the rest now.

> Removing points works fine via the right-mouse menu - very nice!
> Thanks a lot, routing with saving its result is
> (at least for me) a very important feature!!
> Best, Arnd
Same here :-)
Importing routes is still missing, but that's probably a topic for later.


More information about the Marble-devel mailing list