[Marble-devel] Review Request: Double click zooms in, generalized animations, GeoDataLookAt to change observer position
Dennis Nienhüser
earthwings at gentoo.org
Mon Jan 25 18:39:21 CET 2010
> On 2010-01-21 23:26:17, Torsten Rahn wrote:
> > /trunk/KDE/kdeedu/marble/src/lib/MarbleWidget.h, line 1028
> > <http://reviewboard.kde.org/r/2672/diff/1/?file=17486#file17486line1028>
> >
> > Hm, we should move this one into the private class using Q_PRIVATE_SLOT later on ...
> >
> > Also this slot is named like a signal. According to its description it should be named: startStillMode() or something like that
Possible, but the private class needs access to MarbleWidget then (for repainting).
> On 2010-01-21 23:26:17, Torsten Rahn wrote:
> > /trunk/KDE/kdeedu/marble/src/lib/MarbleWidget.h, line 1034
> > <http://reviewboard.kde.org/r/2672/diff/1/?file=17486#file17486line1034>
> >
> > Hm, we should move this one into the private class using Q_PRIVATE_SLOT later on ...
> >
See above (Possible, but the private class needs access to MarbleWidget then (for repainting).)
> On 2010-01-21 23:26:17, Torsten Rahn wrote:
> > /trunk/KDE/kdeedu/marble/src/lib/MarbleMap.h, line 168
> > <http://reviewboard.kde.org/r/2672/diff/1/?file=17481#file17481line168>
> >
> > Shouldn't this be named radiusFromDistance( qreal ) ?
done
> On 2010-01-21 23:26:17, Torsten Rahn wrote:
> > /trunk/KDE/kdeedu/marble/src/lib/MarbleMap.h, line 163
> > <http://reviewboard.kde.org/r/2672/diff/1/?file=17481#file17481line163>
> >
> > Shouldn't this be named distanceFromRadius(int) ?
done (also with qreal as parameter, see comment in the new diff)
- Dennis
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviewboard.kde.org/r/2672/#review3784
-----------------------------------------------------------
On 2010-01-21 22:56:47, Dennis Nienhüser wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://reviewboard.kde.org/r/2672/
> -----------------------------------------------------------
>
> (Updated 2010-01-21 22:56:47)
>
>
> Review request for marble.
>
>
> Summary
> -------
>
> - Default input handler reacts to double click and zooms in (centering the mouse position)
> - Introduces the GeoDataLookAt object as a possibility to change the camera view (observer) in MarbleMap and MarbleWidget
> - Adds FlyToMode enum to generalize the existing Jump animation
> - Extends existing Jump to support source and target with different altitudes. Altitude changed according to travel distance to avoid very high jumps when only moving a short distance
> - Adds Linear interpolation as another animation
> - Adds flyTo methods to change camera view point
> - Adds FlyToMode parameter to existing zoom/pan actions. Those already having a bool animate are unchanged and set FlyToMode=Automatic/Instant internally
> - Some cleanup here and there
>
>
> This addresses bug 168744.
> https://bugs.kde.org/show_bug.cgi?id=168744
>
>
> Diffs
> -----
>
> /trunk/KDE/kdeedu/marble/src/lib/MarbleControlBox.cpp 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarbleMap.h 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarbleMap.cpp 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarbleMap_p.h 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarblePhysics.h 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarblePhysics.cpp 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarbleWidget.h 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarbleWidget.cpp 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarbleWidgetInputHandler.h 1078223
> /trunk/KDE/kdeedu/marble/src/lib/MarbleWidgetInputHandler.cpp 1078223
> /trunk/KDE/kdeedu/marble/src/lib/global.h 1078223
>
> Diff: http://reviewboard.kde.org/r/2672/diff
>
>
> Testing
> -------
>
> KDE and Qt Version, both with animations enabled and disabled.
>
> Expected behavior:
> In non-animated mode: As before, except that double click centers on the mouse position and zooms in.
> In animated mode:
> - Linear animation for wheel zoom actions
> - Jump animation for double click
> - Jump animation when moving to a target not visible on the screen yet
> - Linear animation when moving to a target visible on the screen at the same height
> - Jump animation when moving to a target visible on the screen at a different height (except wheel zoom)
> - Control box zoom and pan buttons as well as keyboard events for zooming and panning are animated
> - Jump animations for "go home" and places selected (unless visible on screen and at the same height, see above)
>
>
> Thanks,
>
> Dennis
>
>
More information about the Marble-devel
mailing list