[Marble-devel] Review Request: Marble Clock Patch

Torsten Rahn rahn at kde.org
Thu Aug 5 11:58:57 CEST 2010


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviewboard.kde.org/r/4819/#review6811
-----------------------------------------------------------



/trunk/KDE/kdeedu/marble/src/QtMainWindow.cpp
<http://reviewboard.kde.org/r/4819/#comment6677>

    I think a comment here would be nice explaining that this dialog is not supposed to be modal and why it's not supposed to be modal.



/trunk/KDE/kdeedu/marble/src/QtMainWindow.cpp
<http://reviewboard.kde.org/r/4819/#comment6678>

    Hm, why not adhere to the timeformat provided via QLocale? In Germany and other countries putting the month in front of the day and the year is not used at all.



/trunk/KDE/kdeedu/marble/src/QtMainWindow.cpp
<http://reviewboard.kde.org/r/4819/#comment6679>

    See comment about QLocale use above.



/trunk/KDE/kdeedu/marble/src/QtMainWindow.cpp
<http://reviewboard.kde.org/r/4819/#comment6684>

    I think that this way of using signals and slots is atypical. Usually the changed datetime would get passed as a parameter.
    Wouldn't this also get around having the clock pointer as a member (which to me looks a bit messy) ? Why do we want to have the clock as a member in here? Just makes the code more complex imho.
    



/trunk/KDE/kdeedu/marble/src/lib/MarbleModel.cpp
<http://reviewboard.kde.org/r/4819/#comment6685>

    Hm, this is a bad name for the method imho. What is the "speed" of a model? That's something nobody will understand. Instead it should be named something like
    
    clockSpeed()
    
    Also: Do we really need a convenience method for this instead of just exposing the clock object?



/trunk/KDE/kdeedu/marble/src/lib/MarbleModel.cpp
<http://reviewboard.kde.org/r/4819/#comment6686>

    see above. Bad naming imho. 
    
    setClockSpeed. 
    
    Do we really need this convenience method? Or does it just clutter up the model class?



/trunk/KDE/kdeedu/marble/src/lib/MarbleModel.cpp
<http://reviewboard.kde.org/r/4819/#comment6687>

    Do we really need this convenience method or wouldn't exposing the clock be good enough? Or do we just not want to expose the clock as a public class? I'm not sure.



/trunk/KDE/kdeedu/marble/src/lib/QtMarbleConfigDialog.h
<http://reviewboard.kde.org/r/4819/#comment6689>

    systemTimezone vs. customTimezone should be an enum from what I understand.



/trunk/KDE/kdeedu/marble/src/lib/QtMarbleConfigDialog.h
<http://reviewboard.kde.org/r/4819/#comment6688>

    what does "UTC()" mean? I don't get what this method does. Please use better naming.



/trunk/KDE/kdeedu/marble/src/marble_part.h
<http://reviewboard.kde.org/r/4819/#comment6681>

    "Show Zenith" is not a proper name imho. 
    
    methods should always be concise and easily tell what the method is about.
    
    So 
    
    void showSunInZenith(bool) might be a better method name.



/trunk/KDE/kdeedu/marble/src/marble_part.h
<http://reviewboard.kde.org/r/4819/#comment6682>

    This doesn't look correct to me. 
    
    The choice is really between 3 different states:
    
    1) Shadow off
    2) Normal Shadow on
    3) Nightmap Shadow on
    
    Two toggle actions buttons don't sufficiently represent this in terms of UI since the nightmap action depends on the shadow action. We need a better solution here.



/trunk/KDE/kdeedu/marble/src/marble_part.cpp
<http://reviewboard.kde.org/r/4819/#comment6683>

    See my comment above about the problematic mapping of the three states to two toggle buttons.



/trunk/KDE/kdeedu/marble/src/plugins/render/stars/StarsPlugin.cpp
<http://reviewboard.kde.org/r/4819/#comment6690>

    YAY, you got it implemented correctly. Very cool :-)


- Torsten


On 2010-08-04 22:13:25, hjain wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://reviewboard.kde.org/r/4819/
> -----------------------------------------------------------
> 
> (Updated 2010-08-04 22:13:25)
> 
> 
> Review request for marble and Bastian Holst.
> 
> 
> Summary
> -------
> 
> This patch has the following features:-
> 1) The older 'Sun Control' dialog box is broken into new 'Sun Control' dialog box and 'Time Control' dialog box.
> 2) The 'Configure Marble Desktop Globe' has 'Date and Time' tab which has configuration features for time.
> 3) The current time is shown in status bar.
> 4) The icon of the Sun is shown on the Earth for zenith feature in 'Sun Control' dialog box.
> 5) Toolbar action button are added for shadow, night map and zenith features(although shadow and night map toolbar buttons are disabled in this patch because of lack of appropriate icons for them).
> 6) The name of ExtDateTime class is changed to MarbleClock. The license of David Roberts(author of ExtDateTime class) has also been updated for this class with this permissions.
> 
> 
> Diffs
> -----
> 
>   /trunk/KDE/kdeedu/marble/src/QtMainWindow.h 1157379 
>   /trunk/KDE/kdeedu/marble/src/QtMainWindow.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/bindings/python/sip/MarbleModel.sip 1157379 
>   /trunk/KDE/kdeedu/marble/src/bindings/python/sip/SunLocator.sip 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/CMakeLists.txt 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/ExtDateTime.h 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/ExtDateTime.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/LayerManager.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/MarbleClock.h PRE-CREATION 
>   /trunk/KDE/kdeedu/marble/src/lib/MarbleClock.cpp PRE-CREATION 
>   /trunk/KDE/kdeedu/marble/src/lib/MarbleDataFacade.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/MarbleModel.h 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/MarbleModel.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/MarbleTimeSettingsWidget.ui PRE-CREATION 
>   /trunk/KDE/kdeedu/marble/src/lib/QtMarbleConfigDialog.h 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/QtMarbleConfigDialog.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/SunControlWidget.h 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/SunControlWidget.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/SunControlWidget.ui 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/SunLocator.h 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/SunLocator.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/TimeControlWidget.h PRE-CREATION 
>   /trunk/KDE/kdeedu/marble/src/lib/TimeControlWidget.cpp PRE-CREATION 
>   /trunk/KDE/kdeedu/marble/src/lib/TimeControlWidget.ui PRE-CREATION 
>   /trunk/KDE/kdeedu/marble/src/lib/blendings/SunLightBlending.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/routing/AdjustNavigation.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/lib/routing/RoutingManager.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/marble.kcfg 1157379 
>   /trunk/KDE/kdeedu/marble/src/marble_part.h 1157379 
>   /trunk/KDE/kdeedu/marble/src/marble_part.cpp 1157379 
>   /trunk/KDE/kdeedu/marble/src/marble_part.rc 1157379 
>   /trunk/KDE/kdeedu/marble/src/marbleui.rc 1157379 
>   /trunk/KDE/kdeedu/marble/src/plugins/render/stars/StarsPlugin.h 1157379 
>   /trunk/KDE/kdeedu/marble/src/plugins/render/stars/StarsPlugin.cpp 1157379 
> 
> Diff: http://reviewboard.kde.org/r/4819/diff
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> hjain
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.kde.org/pipermail/marble-devel/attachments/20100805/e3a09852/attachment-0001.htm 


More information about the Marble-devel mailing list