[Marble-devel] Osm Annotation to the next level
Torsten Rahn
rahn at kde.org
Mon Jun 22 08:14:28 CEST 2009
Hi Andrew,
Am Freitag 19 Juni 2009 02:58:38 schrieb Andrew Manson:
> just wanted to share with you the new stuff that went into the gsoc branch
> tonight ( 5 mins ago ) on revision 983747. I know that some people are not
> following the gsoc branch commit messages.
>
> To see it in action go to http://www.youtube.com/watch?v=XZt2-cj502c and
> have a look.
Looks great!
I've just committed a tiny change to your code that allows the polygon to
follow the earth's surface (that's what the tessellate flag is for). I think I
will change line string, linear ring and polygon so that this will be the
default behaviour though.
Some remarks:
- We've basically standardized on STL-iterators, so it would be nice if you
used those as well. :-)
- Please use latLonAltBox() instead of geoBounding(). In general be careful
about method, class and member naming: We have established standards there and
we are following Qt naming conventions whereever possible.
- Please spellcheck any text strings you commit (your text editor surely has
got a menu entry for this, so there are no excuses)!
- GeoDataPolygon isn't quite done yet, so you might find out that some of its
features don't work (in opposite to GeoDataLinearRing which is thoroughly
tested). This shouldn't keep your from using it but you shouldn't be surprised
if the inner linear rings don't do what you'd expect from them ...
- I've got a few ideas how to improve the UI to create the polygons. I'll
discuss those later with you.
- Signals should be named after what has happened (that's why in Qt they are
usually named like "XXXChanged". We should do the same: so don't name signals
"redraw" but try to describe what has happened. The Slot on the other hand
should describe the action that needs to be executed. This brings me to the
next point:
- Very important: Please have a careful look at:
chaos.troll.no/~shausman/api-design/api-design.pdf
All the rules lined out there are also valid for Marble as Marble is a Qt
library!
Thanks!
Torsten
> I'm sending this email because I might not be around tomorrow, I'm heading
> into the city to get my degree results! Wish Me luck!
>
> chat again soon!
> -Andrew
More information about the Marble-devel
mailing list