D27988: KCM/Compositing: Use KConfig XT in UI

Kevin Ottens noreply at phabricator.kde.org
Fri Mar 27 17:27:02 GMT 2020


ervin requested changes to this revision.
ervin added inline comments.
This revision now requires changes to proceed.

INLINE COMMENTS

> kwincompositing_setting.kcfg:25
> +
> +       <entry name="GLTextureFilter" type="Int">
> +        <default>2</default>

This is asking for name + value (to avoid the dreaded "gL" on the C++ side)

> kwincompositing_setting.kcfg:45
> +
> +       <entry name="GLPreferBufferSwap" type="Enum">
> +           <default>AutoSwapStrategy</default>

ditto

> kwincompositing_setting.kcfg:64
> +
> +       <entry name="GLCore" type="Bool">
> +           <default>false</default>

ditto

> kwincompositing_setting.kcfg:72
> +
> +       <entry name="GLPlatformInterface" type="String">
> +           <default>glx</default>

ditto

> main.cpp:106
>  
> -void KWinCompositingSettings::init()
> -{
> -    using namespace KWin::Compositing;
> -    auto currentIndexChangedSignal = static_cast<void(QComboBox::*)(int)>(&QComboBox::currentIndexChanged);
> +void KWinCompositingKCM::reenableGL() {
> +    m_settings->setOpenGLIsUnsafe(false);

{ should be on its own line

> main.cpp:219
> +
> +    const bool changed = m_glCore != glCore || backend != m_backend || m_animationDurationFactor != animationDuration;
> +    emit unmanagedWidgetChangeState(changed);

I'd split the clauses on several lines for readability

> main.cpp:222
> +
> +    const bool defaulted = glCore != m_settings->defaultGLCoreValue() && backend != m_settings->defaultBackendValue() && animationDuration != m_settings->defaultAnimationDurationFactorValue();
> +    emit unmanagedWidgetDefaultState(defaulted);

ditto (especially for that one the line is getting quite long)

REPOSITORY
  R108 KWin

REVISION DETAIL
  https://phabricator.kde.org/D27988

To: meven, #kwin, ervin, crossi, bport, hchain
Cc: zzag, kwin, Orage, cacarry, LeGast00n, The-Feren-OS-Dev, cblack, jraleigh, zachus, fbampaloukas, GB_2, mkulinski, ragreen, jackyalcine, iodelay, crozbo, bwowk, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, hardening, romangg, jensreuterberg, abetts, sebas, apol, ahiemstra, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kwin/attachments/20200327/c6460091/attachment-0001.html>


More information about the kwin mailing list