D27955: KCM/Compositing: Use KConfig XT to store values

Vlad Zahorodnii noreply at phabricator.kde.org
Fri Mar 20 10:27:22 GMT 2020


zzag added a comment.


  Overall, +1.

INLINE COMMENTS

> compositing.cpp:53
>      , m_compositingInterface(new OrgKdeKwinCompositingInterface(QStringLiteral("org.kde.KWin"), QStringLiteral("/Compositor"), QDBusConnection::sessionBus(), this))
> -    , m_config(KSharedConfig::openConfig("kwinrc"))
> -{
> -    reset();
> -    connect(this, &Compositing::animationSpeedChanged,       this, &Compositing::changed);
> -    connect(this, &Compositing::windowThumbnailChanged,      this, &Compositing::changed);
> -    connect(this, &Compositing::glScaleFilterChanged,        this, &Compositing::changed);
> -    connect(this, &Compositing::xrScaleFilterChanged,        this, &Compositing::changed);
> -    connect(this, &Compositing::glSwapStrategyChanged,       this, &Compositing::changed);
> -    connect(this, &Compositing::compositingTypeChanged,      this, &Compositing::changed);
> -    connect(this, &Compositing::compositingEnabledChanged,   this, &Compositing::changed);
> -    connect(this, &Compositing::openGLPlatformInterfaceChanged, this, &Compositing::changed);
> -    connect(this, &Compositing::windowsBlockCompositingChanged, this, &Compositing::changed);
> -
> -    connect(this, &Compositing::changed, [this]{
> -        m_changed = true;
> -    });
> +    , m_settings(new KWinCompositingSetting(parent))
> +{

Shouldn't the parent be `this`?

> compositing.h:104-107
> +    void updateSettings();
> +
>  private:
> +    void applyValues();

naming nit: could you please rename these methods to something else? It's unclear what values `applyValues` applies.

What about these?

  void updateSettingsFromUi();
  void updateUiFromSettings();

Feel free to ignore this comment because it looks like these methods will go away in D27988 <https://phabricator.kde.org/D27988>

REPOSITORY
  R108 KWin

REVISION DETAIL
  https://phabricator.kde.org/D27955

To: meven, #kwin, ervin, bport, crossi, hchain, zzag
Cc: zzag, kwin, Orage, cacarry, LeGast00n, The-Feren-OS-Dev, cblack, jraleigh, zachus, fbampaloukas, GB_2, mkulinski, ragreen, jackyalcine, iodelay, crozbo, bwowk, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, hardening, romangg, jensreuterberg, abetts, sebas, apol, ahiemstra, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kwin/attachments/20200320/07cc6a1a/attachment.html>


More information about the kwin mailing list