D27955: KCM/Compositing: Use KConfig XT to store values

Vlad Zahorodnii noreply at phabricator.kde.org
Tue Mar 10 17:00:41 GMT 2020


zzag added inline comments.

INLINE COMMENTS

> compositing.cpp:57
> +    load();
> +    connect(this, &Compositing::animationSpeedChanged,       this, &Compositing::onChanged);
> +    connect(this, &Compositing::windowThumbnailChanged,      this, &Compositing::onChanged);

Naming nitpick: onChanged isn't really a great name for a signal. Usually, "on" is used with slots.

What about connecting `Compositing::animationSpeedChanged` to `Compositing::updateSettings`? e.g.

  connect(this, &Compositing::animationSpeedChanged,       this, &Compositing::updateSettings);

> compositing.cpp:299
>  
>      if (m_changed) {
>          // Send signal to all kwin instances

Given that m_changed is not set to true when anything has been changed, there is a chance that we won't send a reinit request.

We probably need to save the return value of `m_settings->isSaveNeeded()` before calling `m_settings->save()` and check it here.

REPOSITORY
  R108 KWin

REVISION DETAIL
  https://phabricator.kde.org/D27955

To: meven, #kwin, ervin, bport, crossi, hchain
Cc: zzag, kwin, Orage, cacarry, LeGast00n, The-Feren-OS-Dev, cblack, jraleigh, zachus, fbampaloukas, GB_2, mkulinski, ragreen, jackyalcine, iodelay, crozbo, bwowk, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, hardening, romangg, jensreuterberg, abetts, sebas, apol, ahiemstra, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kwin/attachments/20200310/4c8731c1/attachment-0001.html>


More information about the kwin mailing list