D21874: Overhaul AbstractOutput
Vlad Zagorodniy
noreply at phabricator.kde.org
Mon Jun 17 11:59:30 BST 2019
zzag created this revision.
zzag added a reviewer: KWin.
Herald added a project: KWin.
Herald added a subscriber: kwin.
zzag requested review of this revision.
REVISION SUMMARY
There are several issues with code of AbstractOutput class:
(a) Some methods are documented, and some are not. In general, we tend
to document all public methods in KWin core. It looks like a very
minor issue, but there are methods that have very ambiguous return
value. One such method is geometry(). It's not obvious whether the
returned geometry is in device independent pixels or not;
(b) There's a mix of methods defined in the cpp file and in the header.
This is not very good because reading such code becomes a bit harder
if you don't use any fancy IDE;
(c) Missing Q_DISABLE_COPY, etc.
This change addresses these issues, so the code is a bit more readable
and easier to work with.
REPOSITORY
R108 KWin
BRANCH
overhaul-abstract-output
REVISION DETAIL
https://phabricator.kde.org/D21874
AFFECTED FILES
abstract_output.cpp
abstract_output.h
To: zzag, #kwin
Cc: kwin, LeGast00n, jraleigh, fbampaloukas, GB_2, mkulinski, ragreen, jackyalcine, Pitel, iodelay, bwowk, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, ali-mohamed, hardening, jensreuterberg, abetts, sebas, apol, mart
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kwin/attachments/20190617/86397c09/attachment-0001.html>
More information about the kwin
mailing list