[Ktechlab-devel] unit test.

P Zoltan zoltan.padrah at gmail.com
Tue Jun 9 17:05:59 UTC 2009


On Mon, 08 Jun 2009 17:54:38 +0200, Alan Grimes <agrimes at speakeasy.net>  
wrote:

>
>>   The thing is that I don't get the "big picture": that is that matrix,
>> a,b, ...
>>
>>   I'll have to read some docs in the topic... Do you recommend  
>> something?
>
> The engine does something like this:
>
> http://en.wikipedia.org/wiki/LU_decomposition
>
> What we're basically doing is solving a system of N equations for N
> variables.
>
> Each equation is of the form:
>
> Ai1X1 + Ai2X2 + Ai3X3 + Ai4X4 = Bi
>
> Where Aij may be 0.
> More information:
>
> http://en.wikipedia.org/wiki/System_of_linear_equations
>
>
> It's a critically important problem. It's the central problem of high
> performance computing. When someone develops a coprocessor board, it
> always supports BLAS. =P
>
> http://www.clearspeed.com/
> http://www.mc.com/
> (and many others...)
>
>

  Thanks for the documentation. In my opinion all these should be  
documented in detail in the wiki. If there was a wiki :\

  Another important aspect of the simulator is how the components place  
their equations in the matrix.

  Some ideas:
  - it would be easier to read if the constructors were the first in the  
.cpp file
  - QuickVector has a memset() in its constructor -- personally I consider  
that potentially dangerous
  - mixing std::cout and kdDebug() output could cause stange output.  
Because the math code is quite general, we could consider using only cout  
for logging there. This could also eliminate any Qt or kde dependencies  
 from the testcase(s).
  - why does Matrix::fbSub have only one parameter, used both for input and  
output? Isn't more elegant (and less error prone) if there were 2  
arguments: "b" and "x" ?

  These days I'm too busy to debug the code, maybe saturday I'll have some  
time.

   Zoltan




More information about the Ktechlab-devel mailing list