[Kst] Re: link step failing with qmake

Peter Kümmel syntheticpp at gmx.net
Wed May 18 20:32:09 CEST 2011

On 18.05.2011 19:42, Nadine Leenders wrote:
> I tried doing build and am back to my original problem, I have the error message:
> /usr/local/lib/libnetcdff_c++.a(netcdf.o): relocation R_X86_64_32S against `vtable for NcTypedComponent' can not be used when making a shared object; recompile with -fPIC
> could not read symbols: Bad value
> collect2: ld returned 1 exit status

Here it tries to link the netcdf plugin, is you netcdf as old as you linux?
If you don't need any special plugins you could disable them by calling in you
cmake build directory:
     cmake . -Dkst_3rdparty=0

> With qmake I was able to get rid of the message by putting "staticlib" as an option to CONFIG in kst.pri .  I tried putting it back there and it seems that  qtcreator doesn't use this file.
> More suggestions?
> Thanks!
>   - Nadine
> _______________________________________________
> Kst mailing list
> Kst at kde.org
> https://mail.kde.org/mailman/listinfo/kst

More information about the Kst mailing list