[Kst] [Bug 161766] New: reset data file option does not work

Andrew Walker arwalker at sumusltd.com
Wed May 7 20:52:53 CEST 2008

------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.
           Summary: reset data file option does not work
           Product: kst
           Version: 1.4.0
          Platform: Compiled Sources
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: NOR
         Component: general
        AssignedTo: kst kde org
        ReportedBy: arwalker sumusltd com

Version:           1.4.0 (using KDE 3.5.8)
Installed from:    Compiled From Sources
OS:                Linux

The following was sent to the kst list by a user:


Really simple problem, but can't make it work. Easy to believe that I'm doing
something stupid, but if so, I can't figure what it is after several days of
poking around and handbook reading and re-reading, so would be grateful for a

I notice a comment in an archived e-mail circa Jan 2008 to the effect that "command
line processing is broken", but am hoping that's either I'm misreading that, or else
command line processing fixed since then.

here's the problem:

I'm trying to display a two-vector plot of "packets sent/packets received v. time".

I create a data file 0.dat:

11      1       1
12      2       1
13      3       2
14      4       4

I run kst:

       kst -x1 -y2 -y3 0.dat&

I see the attached plot0.jpg.

I write out a .kst file (making no changes to any of the curve or vector definitions.)

I create a data file 2.dat by adding two data points to 0.dat:

11      1       1
12      2       1
13      3       2
14      4       4
15      5       5
16      6       5

I run kst:

       kst -F 2.dat 0.kst&

The window displays with the axes etc, but no curves displayed, as in plot2a.jpg.
The Help->Debug Kst->Log window shows the error messages in plot2b.jpg.

I've tried various other things, eg displaying 0.dat, going to data mode, then
changing vectors 2 & 3 to be "read from end", but I get exactly the same error.

       kst -n -1 -F 2.dat 0.kst&

The errors in the log suggest to me that the -F isn't actually resetting the
data file, but maybe I'm reading meaning into the messages that isn't correct.

More information about the Kst mailing list