[Kst] branches/work/kst/portto4/kst/src
Barth Netterfield
netterfield at astro.utoronto.ca
Tue Jul 1 02:24:09 CEST 2008
SVN commit 826571 by netterfield:
Now we can change the names of generated vectors.
M +1 -0 libkstapp/vectordialog.cpp
M +1 -0 widgets/vectorselector.cpp
--- branches/work/kst/portto4/kst/src/libkstapp/vectordialog.cpp #826570:826571
@@ -514,6 +514,7 @@
const int numberOfSamples = _vectorTab->numberOfSamples();
generatedVector->writeLock();
generatedVector->changeRange(from, to, numberOfSamples);
+ generatedVector->setDescriptiveName(DataDialog::tagString().replace(defaultTagString(), QString()));
generatedVector->unlock();
setGenVectorDefaults(generatedVector);
}
--- branches/work/kst/portto4/kst/src/widgets/vectorselector.cpp #826570:826571
@@ -130,6 +130,7 @@
void VectorSelector::editVector() {
QString vectorname;
DialogLauncher::self()->showVectorDialog(vectorname, ObjectPtr(selectedVector()));
+ fillVectors(); // we might have just changed the name, so refill the combo.
emit contentChanged();
}
More information about the Kst
mailing list