[Kst] extragear/graphics/kst

George Staikos staikos at kde.org
Sat May 27 12:48:14 CEST 2006


SVN commit 545327 by staikos:

update changelog

 M  +250 -0    ChangeLog  


--- trunk/extragear/graphics/kst/ChangeLog #545326:545327
@@ -1,3 +1,253 @@
+2006-05-27 09:39  staikos
+
+	* : quote arguments to avoid shell script errors when the variables
+	  are empty BUG: 128041
+
+2006-05-26 17:41  netterfield
+
+	* : The data wizard vector selection widget was changed to be like
+	  other similar widgets within KDE as a whole. This patch makes the
+	  same changes to the plot dialog and to the legend dialog:
+	  -reverses the order so availible is on the left, selected on the
+	  right -uses kiconloader to grab the button icons, so the icons are
+	  themeable -adds up and down methods so order can be selected.
+
+2006-05-25 18:37  arwalker
+
+	* : BUG:127536 Ensure that when mocing sticky borders apply to all
+	  objects and not just top-level objects.
+
+2006-05-25 16:51  arwalker
+
+	* : BUG:124158 Normalize not just the default window, but all the
+	  others as well.
+
+2006-05-25 14:52  staikos
+
+	* : revert most of the last commit. it went horribly horribly wrong.
+	  meanwhile this function needs a redesign.
+
+2006-05-25 13:36  staikos
+
+	* : the recursive part of this function is odd... but anyway let's
+	  add const.
+
+2006-05-25 13:06  staikos
+
+	* : Revert commit 541977 This code does not belong in KstViewObject,
+	  should not be a virtual function, should take const references as
+	  parameters, should use a const iterator, should not use
+	  iVariables, and should be a const function. If anything in there
+	  prevents fixing constness, it's probably pointing to another issue
+	  elsewhere. Anyway, all this belongs in the view, not in each
+	  object. REOPEN: 127536
+
+2006-05-25 12:56  staikos
+
+	* : back out the image changes so we stay with XPM for now. Also
+	  remove the unneeded caption and set UI version to 3.1
+
+2006-05-25 12:48  staikos
+
+	* : no iVariables please. add const.
+
+2006-05-25 12:47  staikos
+
+	* : this drawCursorPos() stuff is impressively inefficient. Move
+	  some variables out of the way for now.
+
+2006-05-24 23:03  arwalker
+
+	* : CCBUG:124158 Combine code for window generation so that it later
+	  only needs to be fixed in one place.
+
+2006-05-24 22:55  arwalker
+
+	* : Name of Hanning window should be Hann.
+
+2006-05-24 21:45  arwalker
+
+	* : BUG:127148 Scale the font size correctly when printing or
+	  exporting labels.
+
+2006-05-24 20:26  arwalker
+
+	* : BUG:127975 Set the printer resolution to give correct scaling.
+
+2006-05-24 19:11  netterfield
+
+	* : cursor offset mode in data mode should offset from the nearest
+	  point when 'c' is pressed, not from the cursor position. This
+	  fixes that.
+
+2006-05-24 18:48  dhanson
+
+	* : BUG:121159 objects with _maintainAspect == true will now
+	  maintain their aspect on parent resize.
+
+2006-05-24 16:54  netterfield
+
+	* : The legend dialog can be used to add or delete curves from the
+	  legend. Previous to this patch, 'apply' in the plot dialog would
+	  undo these changes, and reset the legend contents. This patch adds
+	  a new attribute to legends, which keeps track of whether the plot
+	  dialog should reset the contents of the legend.
+
+2006-05-23 16:40  arwalker
+
+	* : CCBUG:118737 Do not remove '.' from equation name as there is no
+	  good reason to do so.
+
+2006-05-23 14:52  scripty
+
+	* : SVN_SILENT made messages (.desktop file)
+
+2006-05-22 21:20  dhanson
+
+	* : CCBUG:127524 mostly fixed.
+
+2006-05-20 15:05  scripty
+
+	* : SVN_SILENT made messages (.desktop file)
+
+2006-05-18 14:55  scripty
+
+	* : SVN_SILENT made messages (.desktop file)
+
+2006-05-18 07:49  amantia
+
+	* : fix compilation
+
+2006-05-17 21:07  arwalker
+
+	* : BUG:127536 Ensure moving object snaps to edges of all objects
+
+2006-05-16 23:00  dhanson
+
+	* : BUG:121159 Added a _maintainAspect boolean for KstViewObjects,
+	  which allows the default behaviour when resizing objects to be
+	  aspect preserving. Added a checkbox to the KstViewPicture to
+	  enable this option. If this checkbox is enabled when the image
+	  source is selected, then the KstViewPicture will override the
+	  user's initial size choice to maintain the aspect ratio.
+
+2006-05-16 21:47  fidler
+
+	* : NAD datasource plugin with local caching
+
+2006-05-16 21:44  fidler
+
+	* : prefer nad over naddirect
+
+2006-05-16 21:44  fidler
+
+	* : handle errors in data stream
+
+2006-05-16 14:48  scripty
+
+	* : SVN_SILENT made messages (.desktop file)
+
+2006-05-15 20:39  arwalker
+
+	* : Only display Expand/Collapse View Manager context menu item if
+	  appropriate
+
+2006-05-15 20:27  staikos
+
+	* : use the GUI-selected pen BUG: 127393
+
+2006-05-15 19:40  staikos
+
+	* : Fix off-by-one in color parsing BUG: 127381
+
+2006-05-15 18:44  staikos
+
+	* : update changelog
+
+2006-05-15 18:37  staikos
+
+	* : fix parsing of nested attributes BUG: 127380
+
+2006-05-15 18:22  staikos
+
+	* : we don't put void in here anywhere else and the last compiler I
+	  know of that required it was aCC
+
+2006-05-15 17:33  arwalker
+
+	* : CCBUG:121534 Allow any base for the log scale. This is not
+	  currently enabled as further testing is needed. Fix compilation.
+
+2006-05-15 16:25  dhanson
+
+	* : BUG:124986 this should cover all of the ways a curve's legend
+	  entry can be modified.
+
+2006-05-13 22:12  staikos
+
+	* : fix saving Kst files with KIO
+
+2006-05-13 14:52  scripty
+
+	* : SVN_SILENT made messages (.desktop file)
+
+2006-05-12 19:52  arwalker
+
+	* : CCBUG:125888 Print curve legends at proper width
+
+2006-05-12 19:50  arwalker
+
+	* : BUG:125888 Honour the selected maximum line width. Nicolas, I
+	  believe this fixes your problem. If not please enter a new bug
+	  report as this one is beginning to sprawl into multiple unrelated
+	  topics.
+
+2006-05-12 19:02  arwalker
+
+	* : use shartedPtr
+
+2006-05-12 08:36  staikos
+
+	* : Implement \textcolor{color}{text}. The color can be one of: 1)
+	  An entry from X11 rgb.txt 2) #RRGGBB hex RR,GG,BB is unimplemented
+	  but will come one day. This varies from latex significantly, but I
+	  think it's more practical for us.
+
+2006-05-12 07:29  staikos
+
+	* : We've been through this one before. Revert #539423 for this
+	  file. The back buffer is not supposed to ever be null. If it's
+	  null, there is a bug and we need to fix it. It can and will crash
+	  other ways, or produce invalid output.
+
+2006-05-12 07:25  staikos
+
+	* : simplify this function, make it twice as fast on a large object
+	  tree, and fix a bug it was masking (tracking the selection list).
+	  Also remove unused variables and use KstSharedPtr<>
+
+2006-05-12 00:47  dhanson
+
+	* : BUG:127177 rewrote KstTopLevelView::deleteSelectedObjects so
+	  that deep children can be removed.
+
+2006-05-11 19:44  arwalker
+
+	* : CCBUG:125888 Remove special casing for line widths when
+	  switching to monochrome before printing as this is handled in the
+	  paint code.
+
+2006-05-11 08:04  staikos
+
+	* : canParent() is unneeded since we already have it in _container.
+	  Make it use that member, make it non-virtual, rename it to
+	  isContainer(), and make it const.
+
+2006-05-11 02:05  dhanson
+
+	* : BUG:117822 some changes to KstVCurve::distanceToPoint. still
+	  plenty of room for improvement
+
 2006-05-10 22:34  arwalker
 
 	* : remove compiler warning


More information about the Kst mailing list