[Kst] Binding TODO

George Staikos staikos at kde.org
Sat Jan 14 20:46:58 CET 2006


On Saturday 14 January 2006 13:41, George Staikos wrote:
> > // axis time interpretation
> > void ...setAxisInterpretation(bool isIntrpreted, intpretation, display)
> >         // interpretation is one of {JY, CTIME, JD, MJD, RJD, TAI}
> >         // display is one of {JY, Y/M/D_H:M:S, D/M/Y_H:M:S, QT_TEXT,
> > QT_LOCAL, JD, MJD, RJD, KDE_SHORT, KDE_LONG} bool ...isInterpreted()
> > string ...Interpretation() // one of {JY, CTIME, JD, MJD, RJD, TAI}
> > string ...Display() // one of {JY, Y/M/D_H:M:S, D/M/Y_H:M:S, QT_TEXT,
> > QT_LOCAL, JD, MJD, RJD, KDE_SHORT, KDE_LONG}

   This one is really ugly.  I think the bool redundant.  We should have a 
"none" argument instead.  I don't like the string types though.  At least, I 
don't like "Y/M/D_H:M:S" nor do I like "QT_*" and "KDE_*".  What do we really 
_want_ here?  Let's make a good interface on the script side and change Kst 
later.  Also maybe we should use an enumeration like in Line.

> > void ...setMinorTicks(int minorTicks) // -1 means auto
> > void ...minorTicks()
> >
> > void ...setMajorTicks(majorTicks)// majorTicks is one of {COARSE,
> > DEFAULT, FINE, VERYFINE} string ...majorTicks()

  These ones are slightly confusing to me.  

> > bool ...defaultMajorGridColor()
> > bool ...defaultMinorGridColor()

   This is very inconsistent so I left it out.  You can query and set the grid 
colors, but can't set default.  I expect this will change in Kst2DPlot 
eventually so I would hate to bind it at this point.

> > void ...setScaleAuto()
> > void ...setScaleAutoSpike()
> > void ...setSetScaleAC(double range)
> > void ...setScaleExpression(string min, string max)
> > string ...getScaleMode() // one of (AUTO, AUTOSPIKE, AC, EXPRESSION)
> > string ...getScaleMin() // current scale minumum (value or expression)
> > string ...getScaleMax() // current scale maximum (value or expression)

   I guess we want these to be slots:

void scaleAuto([bool spikeInsensitive = false])
void scaleAC() <-- need a better name.  suggestions?
void scaleByExpression(string minExpression, string maxExpression)
string minimumScaleExpression (read-only)
string maximumScaleExpression (read-only)

   The last question is, does "string scaleMode  (read-only)" make sense in 
terms of using it from the script side besides for display purposes?  Or 
should we use an enumeration?  See 
http://kst.kde.org/kstscript/docs/Line.html for an example.

-- 
George Staikos
KDE Developer				http://www.kde.org/
Staikos Computing Services Inc.		http://www.staikos.net/


More information about the Kst mailing list