[Kst] VERY strange problem...

Brisset, Nicolas Nicolas.Brisset at eurocopter.com
Mon Oct 17 19:07:14 CEST 2005


I was advertising kst recently, trying to talk users into switching
over, especially since I wrote the datasource for one of our internal
binary formats. That datasource works fine as tested from my account.
Now, I have a user, logged into the same machine and pointing to the
same installation as me (PATH, LD_LIBRARY_PATH, KDEDIRS) for whom the
first field in the X Axis pull-down list in the datawizard (2nd page) is
always "INDEX", while it is "TIME" for me (as it should be !). This is
especially strange, as the list on the left from which to select Y
vectors is right (TIME is the first entry). This is not only confusing,
but also extremely annoying as selecting INDEX outputs -75 all the time
(the field is not even in the file, no idea where the value comes from)
and the user wanted to plot vectors vs time !
Any hint as to where I should look would be _very much_ appreciated! The
only real difference I can see is that KDEHOME points to different
locations, but we tried moving his KDEHOME away to start with a clean
empty config, and the problem was not solved.
I don't know whether there's an underlying bug, or whether it is linked
with caching things somewhere. It is possible (though not sure) that
this user tried a preliminary version of this datasource where there
might have been some problem, but I don't know where it could be stored,
and would not explain the inconsistency between the two lists (Y fields
and X fields)... I'm puzzled !


More information about the Kst mailing list