[KPhotoAlbum] Problem running in Fedora 28

Robert Krawitz rlk at alum.mit.edu
Wed May 16 18:28:34 BST 2018

On Wed, 16 May 2018 15:54:24 +0100, =?UTF-8?Q?Constantin_Or=C4=83san?= wrote:
> Hello,
> here is the information about exiv2
> Name        : exiv2
> Version     : 0.26
> Release     : 8.fc28

That looks fine.

> I reduced my photo collection to one photo and the program still crashes.
> (tried with a few photos all that were imported in the past). I can obtain
> the metadata with exif2 without a problem, so it does not seem to be caused
> by a particular photo.
> I also tried when there is a video (but I have no support for generation of
> thumbnails from videos) and it still crashes.

Can you recompile with debugging enabled (Tobias, how do you do that)?

I'm doing a lot of work in that area right now, but I'm not quite
ready to submit a patch/PR/push.  If the crash is QTimer-related, my
latest bits may just fix it.
Robert Krawitz                                     <rlk at alum.mit.edu>

***  MIT Engineers   A Proud Tradition   http://mitathletics.com  ***
Member of the League for Programming Freedom  --  http://ProgFree.org
Project lead for Gutenprint   --    http://gimp-print.sourceforge.net

"Linux doesn't dictate how I work, I dictate how Linux works."
--Eric Crampton

More information about the Kphotoalbum mailing list