[KPhotoAlbum] image decoding priorities & multithreading
jkt at gentoo.org
Fri Jun 27 17:26:26 BST 2008
Henner Zeller wrote:
> Re: container
> Instead of having a new stl container (std::priority_queue) here
> (which Jesper probably would like to avoid), can't we just use the
> QSet (as before) that is just sorted by priority ? I just had just a
> quick look right now, so I might be missing something.
> Re: addRequest
> Does it suffice to change the priority and priority_queue does take
> care of the proper sorting ? Then using std::priority_queue seems to
> be actually the way to go ;-)
Actually nope, my bad, I misunderstood what the manual said. I'll
probably rework the patch to work with multiple "old fashioned queues".
> Re: typedef
> I'd name the tupe QueueType or something not _queueType. From my
> perspective, a type should be an uppercase name. Underscores should
> only be used in member variables (however, this is only my quick take
> not knowing the details yet of coding conventions in KPA)
We use CamelCapsStartingInUppercase for type names, and usually
_prefixedVariables as private member variables. So I should probably go
for _QueueType :).
More information about the Kphotoalbum