[KimDaBa] new (and perhaps final) snapshot : Compile Error with libkipi

Reimar Imhof Reimar.Imhof at netcologne.de
Sat Oct 2 22:50:04 BST 2004

Am Samstag, 25. September 2004 10:59 schrieb Jesper K. Pedersen:
> A new kimdaba snapshot are now available in
> http://ktown.kde.org/kimdaba/snapshots/
> This might very well be the final snapshot before 2.0 is released.
> So if you want to be sure to enjoy all the new things in 2.0, then it might
> be a very good thing to try the snapshot. YOU might be the one with a
> system setup where kimdaba do not compile out of the box, so lets find it
> now, so we can be sure 2.0 also works on your machine, pleasssse. ;-)
Hi Jesper, hi KimDaBa-users,

I've got a compile error with libkipi-2004-09-25.
I did a ./configure --prefix=/opt/kde3 like I used to do with every snapshot / 
version. (Yes, I tried to compile libkipi after I compiled and installed 

Thats my make output:
##### Begin #######

ri at linux:~/compile/kimdaba-kde-32/2004-09-25/libkipi-2004-09-25-noi18n> make
make  all-recursive
make[1]: Entering directory 
Making all in libkipi
make[2]: Entering directory 
if /bin/sh ../libtool --silent --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I.. 
-I../libkipi -I/opt/kde3/include -I/usr/lib/qt3/include -I/usr/X11R6/include   
-DQT_THREAD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef 
-ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion 
-Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 
-Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new 
".deps/interface.Tpo" -c -o interface.lo interface.cpp; \
then mv -f ".deps/interface.Tpo" ".deps/interface.Plo"; else rm -f 
".deps/interface.Tpo"; exit 1; fi
interface.cpp:215:25: interface.moc: No such file or directory
make[2]: *** [interface.lo] Fehler 1
make[2]: Leaving directory 
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory 
make: *** [all] Fehler 2

###### End ######

I've got no idea why the interface.moc file wasn't created. I tried to figure 
out the differences between this snapshot (2004-09-25) and the one before 
(2004-09-11) but I didn't find any solution.

There's also another strange thing:
Configure complained about 
	can't open ./libkipi/libkipi.pc.in: No such file or directory
But I think that problem doesn't cause the compile error.
(I've tried a second configure (from a new clean libkipi directory) with a 
copy of libkipi.pc.in within the libkipi direkctory. That still gave the 
compile error described above.)

Could you please tell me how to compile this libkipi snapshot?

I'm using kde 3.3.0-something and qt 3.3.3-something (the latest suse rpms for 
suse 8.2).

Thanks a lot

More information about the Kphotoalbum mailing list