[KimDaBa] KimDaBa on Cygwin and OSX

Daniel Berger daniberger at gmx.ch
Mon Mar 15 13:13:57 GMT 2004

Jesper K. Pedersen wrote:

>On Thursday 11 March 2004 11:03, Daniel Berger wrote:
>>Jesper K. Pedersen wrote:
>>>On Thursday 11 March 2004 10:19, Daniel Berger wrote:
>>>>Hello List
>>>>I tried to compile KimDaBa on cygwin, but it didn't worked.
>>>>I'm thinking to buy an Apple Power- or iBook, and I saw on different
>>>>Newssites that some guys managed to get Konqueror and several other KDE
>>>>Apps on OSX natively working. Would this be possible with KimDaBa too?
>>>I'm sure this must be possible, I haven't tried it yet though.
>>>I'd be very interesting in hearing about it if you try it, and I'd be very
>>>happy to help with any modifications needed to KimDaBa.
>>>If you dont have time to do it yourself, but do have pointers to what to
>>>do, please let me know.
>>I just gave KimDaBa 1.1 on cygwin (Windows 2000) a second try.
>>bash-2.05b$ uname -a
>>CYGWIN_NT-5.0 dani-pc 1.5.6(0.108/3/2) 2004-01-19 00:43 i686 unknown
>>unknown Cygwin
>>bash-2.05b$ ./configure
>>checking for mcopidl... not found
>>configure: error: The important program mcopidl was not found!
>>Please check whether you installed aRts correctly or use
>>--without-arts to compile without aRts support (this will remove
>>bash-2.05b$ ./configure --without-arts
>>configure: error: invalid package name: arts
>>Hmm. what now?
>I know nothing about cygwin, I'm afraid.
>Anyone else?

I asked in the forums of kde-cygwin at
about the message.

This was the answer, and fixed the configure error, by just returning 
true for the missing functions.
But maybe the mkdtemp is dependant on mcopidl? (see make error below)

ln -s true /bin/mcopidl
ln -s true /bin/artsc-config

But now I get an error when running make:

ktempdir.cpp: In member function `bool KTempDir::create(const QString&, 
ktempdir.cpp:77: error: `mkdtemp' undeclared (first use this function)
ktempdir.cpp:77: error: (Each undeclared identifier is reported only 
once for each function it appears in.)
make[3]: *** [ktempdir.lo] Error 1
make[3]: Leaving directory `/home/daniel/kimdaba-1.1/kimdaba/compat'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/daniel/kimdaba-1.1/kimdaba'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/daniel/kimdaba-1.1'
make: *** [all] Error 2

I think there's a missing 'include' for qt (or where ever mkdtemp is 
defined) in the makefile?
Maybe I've to add a --configure--blabla-dir = /bla/bla.

regards Dani

More information about the Kphotoalbum mailing list