D17244: Edit Profile Dialog UI redesign

Nathaniel Graham noreply at phabricator.kde.org
Thu Nov 29 21:18:19 GMT 2018


ngraham added a comment.


  This is just awesome. I have some inline comments to really polish the heck out of it:

INLINE COMMENTS

> EditProfileAdvancedPage.ui:175
> +       <property name="text">
> +        <string>Reverse URL hint numbering:</string>
> +       </property>

In general, we try not to do
`<thing> [x] Enabled`.
Instead, do
`[x] <thing>`

If this would be awkward because there are no left labels, try to group them together and give the first one a "miscellaneous" or "general" label. Here's how it would look for this:

  Miscellaneous: [ ] Reverse URL hint numbering
                 [ ] Allow blinking text
                 [ ] Flow control
                 [ ] Bi-directional text rendering

> EditProfileAppearancePage.ui:310
> +           <property name="text">
> +            <string>Set cursor color to match current character</string>
> +           </property>

This could probably be shortened to just "Match current character"

> EditProfileAppearancePage.ui:397
> +           <property name="text">
> +            <string>Blinking:</string>
> +           </property>

It might not be the worst thing in the world to just remove the //right// label for this, and end up with:

  Blinking: [ ]

> EditProfileAppearancePage.ui:607
> +              <property name="text">
> +               <string>Show hint for terminal size after resizing</string>
> +              </property>

This could probably skip the group box and be:

  Window: [x] Show hint for terminal size after resizing
          [ ] Dim colors when inactive

> EditProfileScrollingPage.ui:155
> +       <property name="text">
> +        <string>Scrollbar:</string>
> +       </property>

I think this would actually be simpler and better as a three-item radio button:

  Scrollbar position: (o) Right side
                      ( ) Left side
                      ( ) Hidden

> HistorySizeWidget.ui:43
>         <property name="text">
> -        <string>Fixed size scrollback:</string>
> +        <string>No scrollback</string>
>         </property>

We could probably remove the word "scrollback" from these strings, since the radio buttons' left label already uses it. So we would have:

  Scrollback: (o) Fixed size
              ( ) Unlimited
              ( ) none

REPOSITORY
  R319 Konsole

REVISION DETAIL
  https://phabricator.kde.org/D17244

To: mglb, #konsole, #vdg
Cc: abetts, ngraham, konsole-devel, maximilianocuria, hindenburg
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/konsole-devel/attachments/20181129/fbe46618/attachment-0001.html>


More information about the konsole-devel mailing list