D13147: Replace setUserTitle() with setSessionAttribute()
Ahmad Samir
noreply at phabricator.kde.org
Sun May 27 12:59:02 UTC 2018
ahmadsamir created this revision.
ahmadsamir added a reviewer: Konsole.
Restricted Application added a project: Konsole.
Restricted Application added a subscriber: konsole-devel.
ahmadsamir requested review of this revision.
REVISION SUMMARY
Session:setUserTitle() changes various attributes of the current
session/tab, not just the title; change the name from "Title" to
"sessionAttribute" as that's more representative of what the function
does. Propagate the change to where appropriate throughout the code.
Remove Vt102Emulation::requestWindowAttribute(), as it's not used
anywhere.
Update a couple of links to Qt and XTerm documentation, respectively.
TEST PLAN
Every thing should work as before, for example changing the window title:
- "Show window title on the titlebar" must be enabled
- unset PROMPT_COMMAND (in case it already sets the window title)
- Change the window title:
`printf "\033]2;%s\007" "testing"`
REPOSITORY
R319 Konsole
BRANCH
replace-setUserTitle (branched from master)
REVISION DETAIL
https://phabricator.kde.org/D13147
AFFECTED FILES
src/Emulation.h
src/Session.cpp
src/Session.h
src/SessionController.cpp
src/SessionController.h
src/Vt102Emulation.cpp
src/Vt102Emulation.h
To: ahmadsamir, #konsole
Cc: konsole-devel, #konsole, herrold, ngraham, maximilianocuria, hindenburg
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/konsole-devel/attachments/20180527/04c6aa26/attachment.html>
More information about the konsole-devel
mailing list