compile failure with git master

Jack ostroffjh at
Sun Dec 31 18:00:27 UTC 2017


On 2017.12.31 11:42, Thomas Baumgart wrote:
> On Sonntag, 31. Dezember 2017 11:33:42 CET Jack Ostroff wrote:
> > With a fresh pull from git master, I get a compile failure
> >
> > [ 20%] Building CXX object
> >  
> kmymoney/dialogs/CMakeFiles/dialogs.dir/kreportconfigurationfilterdlg.cpp.o
> >  
> /path-to-source/kmymoney/dialogs/kreportconfigurationfilterdlg.cpp:61:33:
> > fatal error: ui_reporttabgeneral.h: No such file or directory
> >   #include <ui_reporttabgeneral.h>
> >
> > Looking at an old build folder I still have, that file appears in
> > /path-to build/kmymoney/widgets/.  If I cd to that directory, type
> > "make" there, and then resume make in the top build directory, it
> > completes with no errors.
> >
> > I suspect that some recent change to the CMake files changed the  
> order
> > of things.

Well, I also discovered two new build (actually cmake) issues.  First,  
it appears that building OFX is no longer the default.  I had to  
explicitly add -DENABLE_OFXIMPORTER=TRUE to my cmake line, because  
without it, it did NOT enable ofx.  (We also need to update README.ofx  
- I'll try to do that later today.)  Anyway, I also had some moc  
related warnings on "make install" but we'll see if they also go away  
if I fix this problem.  In addition, "Generate API documentation with  
Doxygen" is now "yes" and I don't think it used to be, and I know I do  
not address it directly in my cmake command.

> Strange.  
> shows no problems with a build from scratch. And the part you mention  
> is not
> optional.
> Try the following:
>   cd <<your build directory>>
>   mv CMakeCache.txt CMakeCache.txt.old
>   cmake <<any options you need>>  <<your src directory>>
>   make
OK, I started with an empty build dir, did cmake (with the explicit  
enabling of ofx,) and got the same error.  I then renamed  
CMakeCache.txt and reran cmake.  Same error.
My cmake command is

cmake -DCMAKE_BUILD_TYPE=Debug  

and my build directory is parallel to the source directory.  However, I  
also tried with the build directory under the source directory, and had  
the same result.
> in case cmake worked
cmake doesn't produce any errors, but make still fails.
>   rm CMakeCache.txt.old
> Regards
> Thomas Baumgart
just in case it matters, I have cmake 3.9.6, and Gnu make 4.2.1.  I'm  
currently using gcc 6.4.0.


More information about the KMyMoney-devel mailing list