Review Request 128817: Restructure pages in CSV Importer

Łukasz Wojniłowicz lukasz.wojnilowicz at gmail.com
Sat Sep 10 09:45:45 UTC 2016


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/128817/
-----------------------------------------------------------

(Updated Sept. 10, 2016, 9:45 a.m.)


Status
------

This change has been marked as submitted.


Review request for KMymoney.


Changes
-------

Submitted with commit ca1b1280ee1a3af94983c4d5cb64ee47f21803d9 by ?ukasz Wojni?owicz to branch master.


Repository: kmymoney


Description
-------

I actually decided to get rid of completion page and restructure LinesDate page. In my opinion it's more logical now and better structured for new feature I introduced ie. calculate fee column on fly.

1) shortened updateDecimalSymbol and renamed it to
validateDecimalSymbol,
2) introduced detectDecimalSymbol for autodetecting decimal symbol,
3) simplified createStatement,
4) simplified and deduplicated slotImportClicked,
5) new decimal symbol option 'auto' for columns with various decimal
symbols,
6) decimal symbol and date format get checked every time formats page is
being opened,
7) removed completion page,
8) introduced rows page after separator page which is usefull for
calculate fee
9) introduced formats page which groups all validity checks in one
place,
10) checking securities existence is now part of
InvestmentPage::validatePage(),
11) validateDateFormat operates on tableWidget and not on m_lines so it
can be faster,
12) renamed page labels so they represent the content better,
13) Rows and Formats page have layout equal to Separator page, so look is more consistent.


Diffs
-----

  kmymoney/plugins/csvimport/CMakeLists.txt 216c79c 
  kmymoney/plugins/csvimport/completionwizardpage.ui 616e0c3 
  kmymoney/plugins/csvimport/csvdialog.h 59e6898 
  kmymoney/plugins/csvimport/csvdialog.cpp ed9e1d8 
  kmymoney/plugins/csvimport/csvwizard.h ecec5b0 
  kmymoney/plugins/csvimport/csvwizard.cpp b576dea 
  kmymoney/plugins/csvimport/csvwizard.ui 723e128 
  kmymoney/plugins/csvimport/formatswizardpage.ui PRE-CREATION 
  kmymoney/plugins/csvimport/investprocessing.h 902f9bb 
  kmymoney/plugins/csvimport/investprocessing.cpp f050441 
  kmymoney/plugins/csvimport/lines-datewizardpage.ui 84c1c91 
  kmymoney/plugins/csvimport/rowswizardpage.ui PRE-CREATION 
  kmymoney/plugins/csvimport/separatorwizardpage.ui 2ad5abd 

Diff: https://git.reviewboard.kde.org/r/128817/diff/


Testing
-------


Thanks,

Łukasz Wojniłowicz

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kmymoney-devel/attachments/20160910/42b0615c/attachment.html>


More information about the KMyMoney-devel mailing list