strange network problem updating online accounts

Jack ostroffjh at
Thu Apr 14 15:55:38 UTC 2016

On 2016.04.14 09:35, Thomas Baumgart wrote:
> On Wednesday 13 April 2016 16:56:19 Jack wrote:
>> For the past few days, every time I try to update an online account  
>> (libofx) I get a popup "Unknown host not found" but I  
>> can put that exact host name into Firefox and get a good result.  I  
>> also get no error using that name in a ping command.  Traceroute  
>> often times out before reaching the host, but it does get a good IP  
>> address to use.
> >
>> This happens for all of my online accounts, including banks, credit  
>> cards, and investment accounts.
> >
>> I'm at a loss as to where the problem actually occurs, since DNS is  
>> obviously able to look up the address, and the address can be  
>> reached.
> >
> > Any other thoughts about how I can further troubleshoot this?
> Wireshark is your friend to see what is going on between client and  
> server.

I actually tried that, and didn't see any related packets.  I then  
tried strace, and saw KMM sending a dbus message (including the related  
URL).  I then used "dbus-monitor --session" and it looks to me like KMM  
is handing the URL to some KDE utility or service, and I don't see  
anything I can interpret until the failure message is returned.  I'm  
guessing that KDE service has a stale or corrupt cache.  When I return  
after the weekend, I'll just log out/log in and see if that resets dbus  
and the KDE stuff.  I don't think it's worth the effort it will  
probably take to fully debug and find out the actual cause.


More information about the KMyMoney-devel mailing list