[Kmymoney-devel] [Bug 263983] Cannot open Database on start of KMyMoney.

Russ Fineman upscope at nwi.net
Sun Mar 6 19:37:11 CET 2011


--- Comment #8 from Russ Fineman <upscope nwi net>  2011-03-06 19:37:10 ---
(In reply to comment #7)
> I still cannot duplicate this. I tried changing my LastUsedFile to use secure
> mode, in case it was something in there that was not fixed in the October 2010
> patch. I still successfully connect. 
> I may be missing something, though...  Ideas?

Just tried on openSUSE 11.4 (RC2) with KMyMoney kmymoney-4.5.3-22.2.x86_64.

Get same result. Error when starting, from GUI or command line. If I start with
 .kmy file instead of database, it starts fine. I can then go to File -->
opendata base, select MYSQL  and enter password, it works fine. The other
parameters are there but Mysqlite is also shown.

When starting after shutting down using the database, I get the following

 Cannot open database

 Error in function int MyMoneyStorageSql::upgradeDb() : Error retrieving file
 Driver = QMYSQL, Host = localhost, User = finemanruss, Database = 
 Driver Error: 
 Database Error No -1: 
 Error type 0
 Executed: SELECT version FROM kmmFileInfo;
 Query error No 1046: No database selected QMYSQL: Unable to execute query
 Error type 2

Only apparent difference is on startup, QMYSQL - MYSQL is shown, all parameters
are greyed out except password. When Starting from File - opendatabase, all
parametes are enabled, databases QSQLITE - SQLite Version 3 and QMYSQL - MYSQL
choices are presented. Parameters are all there except password. Selecting
QMYSL and entering password brings up the database fine.

I will be doing complete clean install when openSUSE 11.4 is released later
this week. See if that makes a difference. 

This also happens on openSUSE 11.3 with same hardware except it is on a
separate disk drive. 

If you need anything else let me know or if you need a test run.

Note: my 11.3 version has a hand installed version of KMyMoney from working
with your group on the problem of duplicate entries in the database. 11.4 is
installed from openSUSE 11.4 repo's.

Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the KMyMoney-devel mailing list