[Kmymoney-devel] OFX Madness

Jack ostroffjh at sbcglobal.net
Wed Aug 24 23:16:30 UTC 2011

I'm starting a new thread for this, because I think it's going to take  
a bit of effort to figure out this mess - and we probably only need the  
final conclusion in the bug report itself, not all the interim stuff.   
My main question right now is whether we can come up with any plan of  
attack on this - we seem to have a number of attempts to map accounts  
failing with different unhelpful error messages, from a variety of  
institutions, with no help from those institutions.  Some of these  
mappings were thought to have worked previously.  Other than continuing  
to try with each of my accounts, I don't quite now what else to do.

Is there any chance we could get some help from the libofx team?  I'm  
not even sure right now what we would ask of them.

In terms of one more specific example, today I realized that one of my  
Merrill Lynch accounts was already mapped.  (I haven't been using  
online update because of the issues of mixing cash and investment  
transactions in the same account, but I'll leave that for another  
rant.)  I just did an on-line update, and it worked fine.  I then  
unmapped the account, and when trying to re-map it, I get

attempt your login again. If you continue to have difficulty, please  
call 1.800.MERRILL  
Lynch&Co., Inc.<FID>5550</FI></SONRS></SIGNONMSGSRSV1></OFX>

which is what I got earlier trying to map my one unmapped ML account.

I spent a while on the phone with Merrill Lynch this afternoon.  The  
best he was able to tell me is that this error usually shows up when  
using an incorrect name or password.  However, despite the fact that I  
don't use Quicken, I managed to get him to escalate the call - so  
hopefully someone with more specific information about their OFX  
handling will look at it, but probably not for several days.  In  
addition, he said that what he was able to see in their logs was that  
all my attempts at connections were listed as successful, but he  
couldn't tell me why if it was successful, it gave me an error to try  

One other interesting thing - the existing mapping uses Quicken Windows  
2008 (QWIN 1700 from the log) which should not work, since by agreement  
with Intuit, they only support the current and two previous versions.   
I suspect their logic for for serving transactions for a stated account  
is different from that for providing a list of accounts.  I have not  
yet tried changing this within the kmy file to see if it affects my  
ability to download transactions.

One more question - are all these recent failures in the US, or are  
there any elsewhere?

Thanks for any suggestions.


More information about the KMyMoney-devel mailing list