[Kmymoney-devel] [Bug 241162] New: Ledgers View weird display issue

aga aganderson at ukonline.co.uk
Wed Jun 9 02:07:46 CEST 2010


           Summary: Ledgers View weird display issue
           Product: kmymoney4
           Version: unspecified
          Platform: openSUSE RPMs
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: NOR
         Component: general
        AssignedTo: kmymoney-devel at kde.org
        ReportedBy: aganderson at ukonline.co.uk

Version:           unspecified (using KDE 4.3.5) 
OS:                Linux

This started off being pretty weird, but has become even weirder!

I'd imported a QIF file and opened a transaction.  While it was open, I
happened to click on another entry.  For some reason that now escapes me, this
kmy file is denominated in Canadian Dollars, and what happens is that the
price/currency editor opens.  I clicked to cancel it, and the original screen
display is now a combination of the normal screen with the opened transaction
superimposed over it.  It's possible to repeat the sequence and have the
appearance of several transactions open at the same time.  In fact, it's not
just the appearance of several items being ope,, they all appear to respond as
though they are all actually open.  Clicking to cancel the open transaction
does not rectify the display, but switching to another account and back
restores normality.

Closing the file then reopening it, and reimporting a qif file and repeating
the above gets the same result.

If KMM is closed and reopened with a different, non-foreign currency involved,
there is no problem.  However, once the problem situation has been produced, it
will show in a single currency file.

The imported file happened to be an investment file, so I thought to try a
checking account.  To avoid disturbing the present situation, I tried v1.03 and
opened a checking account there.  Trying the same sequence did not produce a
problem, so, while still in v1.03, I switched to an investment account, and
immediately it opened it was showing the same superimposition that v3.98
showed, even though I hadn't touched the display in any way.  Switching back to
the checking account showed it to be as normal, and returning to the investment
account showed it still to be corrupted.

Reproducible: Always

Steps to Reproduce:
1) Open a multi-currency file.
2) Import an investment file.
3) Double click to edit a transaction.
4) Click on another transaction.
5) Click No on the close dialog box.
6) Cancel the Exchange/Price editor.
7) The corruption is now showing.
8) Click cancel, which does not clear it.
9) Go to 3) and repeat.

a) Close the file without saving and reopen it.
b) Reopen the account in question.
c) The display of an open transaction appears on an otherwise blank ledger
d) Close KMM and reopen and all back to normal, unless....

Happens in both 3.98 and 1.03.

Actual Results:  
As described.

Expected Results:  
Clicking No in step 5) should just close the opened transaction.

Haven't been asked for the app. version no.  It's Version 3.98.2-svn1132481
(and 1.03)

Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the KMyMoney-devel mailing list