Base class for u16 color models?

Boudewijn Rempt boud at valdyas.org
Tue Aug 9 21:34:02 CEST 2005


On Tuesday 09 August 2005 21:29, Casper Boemann wrote:
> On Tuesday 09 August 2005 21:12, Boudewijn Rempt wrote:
> > > > And so on... And of course, the same for the 32bit float & integer
> > > > colorspace once Adrian has those done. I like the prolog & epilog
> > > > composite macros in the 16 bit rgb a lot, by the way :-) -- but maybe
> > > > we can move the bitBlt with the switch that actually does calls the
> > > > composition routines into KisStrategyColorSpace?
> > >
> > > but wouldn't that just be duplicated code in every colorspace
> >
> > No -- at the moment there's a lot of duplicated code; I want to move as
> > much of that as possible to the base class and have only the dedicated
> > composite ops in the color classes.
>
> oh, I was just talking about the bitblt, from the painter. Do you want to
> move that generic code into every colorspace?

Currently there's a bit of code, often with lines commented out in every color 
strategy that goes like 

switch(op)
	COMPOSITE_OVER
		composite_over()
	COMPOSITE_BLA
		composite_bla()

and I want to put that in the KisStrategyColorSpace, together with empty 
implementations for all the composite_bla()'s -- meaning that the subclasses 
can choose which stub to override, and put the overridden stubs in the list 
with supported ops.

> either one I think. I was just confused, because you hadn't mentioned XYZ
> earlier in the mail at all. But I agree.

Okay.

-- 
Boudewijn Rempt 
http://www.valdyas.org/fading/index.cgi
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mail.kde.org/pipermail/kimageshop/attachments/20050809/37102e75/attachment.pgp


More information about the kimageshop mailing list