freak at codepimps.org
Sun Jan 18 16:21:40 CET 2004
On January 18, 2004 10:19 am, Patrick Julien wrote:
> On January 18, 2004 10:09 am, Boudewijn Rempt wrote:
> > On Sun, 18 Jan 2004, Patrick Julien wrote:
> > > Boudewijn,
> > >
> > > The members you removed from KisResource are necessary in order to
> > > support things like animated brushes.
> > I am working on those right at the moment. I have slightly different
> > implementation in mind, one where the user of the brush doesn't need to
> > ask for a particular frame of the brush, but rather asks for the next
> > one.
> Yes, that what was there, nextCycle(). The name is generic since it is in
> the base class.
In any case, I believe that iterators should be the way to do this.
More information about the kimageshop