[Kget] Fwd: Re: [PATCH] New Drop-Target-Download-Dialog

Lukas Appelhans l.appelhans at gmx.de
Tue Oct 2 14:11:17 CEST 2007


Hi!
I wrote a new patch... so I looked for the backtrace and now I know, that a 
TransferList is added, if only one Link is dropped, too...
So, how can I test the "real" Transfer-List feature... is there a TransferList 
for testing???

Cheers

boom1992

PS: I added the current state as attachment :-)


Am Montag, 1. Oktober 2007 22:10:15 schrieben Sie:
> Just as you said,
> one method with showNewTransferDialog(QString url) and another with a
> list of urls
> showNewTransferDialog(QStringList url)
> and in the newTransferDialog show an url requester with one url or a
> qlistwidget if a list is passed.
>
> What do you think about it?
>
> On 10/1/07, Lukas Appelhans <l.appelhans at gmx.de> wrote:
> > Am Montag, 1. Oktober 2007 13:22:36 schrieben Sie:
> > > Looks great!
> > >
> > > Maybe i'ts unimportant but in the
> > > NewTransferDialog::showNewTransferDialog(QString url) you have a very
> > > curious way of putting the bracets :
> > >
> > > if(url.isEmpty())
> > > +    {KUrl clipboardUrl =
> > > KUrl(QApplication::clipboard()->text(QClipboard::Clipboard).trimmed());
> > > +        if (clipboardUrl.isValid())
> > > +            url = clipboardUrl.url();
> > > +    disableUrlRequester = false;}
> > >
> > > And what's happens when you copy a list of links,
> > > was the old code wrong ?
> >
> > No, but it's hard to implement this back... I think it's best when we
> > make a new function like "showNewTransferDialog(QDropEvent * event) only
> > for this, but then we have 2 different functions, too...
> > Or we give "QString url, KUrl::List list" to the function...
> >
> > Do you have an other idea or wich is the best??
> >
> > Cheers
> >
> > boom1992
> >
> > > On 10/1/07, Lukas Appelhans <l.appelhans at gmx.de> wrote:
> > > > Am Montag, 1. Oktober 2007 11:54:17 schrieben Sie:
> > > > > What if you declare the method this way in the class
> >
> > NewTransferDialog:
> > > > > static void showNewTransferDialog(QString url=QString());
> > > > >
> > > > > this way we don't need to change anything in the existing code (Ej.
> > > > > the slotNewTransfer in the MainWindow)
> > > >
> > > > Ok, I have implemented this...
> > > >
> > > > > maybe you should follow the current codestyle guidelines (the
> > > > > HACKING file in kget) ;)
> > > > > i have to pay more attention to this guidelines too :)
> > > >
> > > > Sry, hope it is fixed now :-)
> > > >
> > > > > On 10/1/07, Lukas Appelhans <l.appelhans at gmx.de> wrote:
> > > > > > ----------  Weitergeleitete Nachricht  ----------
> > > > > >
> > > > > > Betreff: Re: [Kget] [PATCH] New Drop-Target-Download-Dialog
> > > > > > Datum: Montag, 1. Oktober 2007
> > > > > > Von: Lukas Appelhans <l.appelhans at gmx.de>
> > > > > > An: Javier Goday <jgoday at enmacosa.com>, kget at kget.org
> > > > > >
> > > > > > Am Montag, 1. Oktober 2007 10:15:46 schrieben Sie:
> > > > > > > On Monday 01 October 2007 01:26:34 Lukas Appelhans wrote:
> > > > > > > > Hi!
> > > > > > > > I wrote a patch to make the Drop-Traget-Download-Dialog like
> > > > > > > > the
> > > >
> > > > one,
> > > >
> > > > > > > > when you click on "New Download"-Button. There's now the "Set
> > > > > > > > as default folder"-Option, too, of course.
> > > > > > > > So, hope you enjoy it and post comments please :-D
> > > > > > >
> > > > > > > Awesome man, great !
> > > > > >
> > > > > > Thx
> > > > > >
> > > > > > > would be great if you can merge the two methods in
> > > > > > > NewTransferDialog class static void showNewTransferDialog();
> > > > > > >      static void showNewTransferDialog(QString url);
> > > > > > >
> > > > > > > in only one with a default parameter QString url = "" or
> >
> > something,
> >
> > > > > > > this way avoid  duplicate code
> > > > > >
> > > > > > Yeah, we can make sth like
> > > > > > if(url.isEmpty())
> > > > > > url=<Clipboard>
> > > > > >
> > > > > > So, I posted a patch as an attachment, this should works fine...
> > > > > >
> > > > > > > > PS: Perhaps the dialog when you use "Save Link As" in
> > > > > > > > Konqueror should look like this, too, but don't know, I think
> > > > > > > > it would not be
> > > >
> > > > a
> > > >
> > > > > > > > big problem to change it
> > > > > > >
> > > > > > > I think you are right, this would be great !
> > > > > > > And maybe this could fix a problem from
> > > > > > >  KHTMLPopupGUIClient class, wich is used by the konqueror to
> > > > > > > show the
> > > > > >
> > > > > > 'Save
> > > > > >
> > > > > > > as Link' (i think), and already ask the user for a destination
> > > > > > > folder, calls to kget this way 'kget source destination'
> > > > > > > and kget can't recognize the destination folder this way,
> > > > > > > asking again to the user !
> > > > > >
> > > > > > Ok, I will look at this... :-)
> > > > > >
> > > > > >
> > > > > > Cheers boom1992
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > -------------------------------------------------------
> > > > > >
> > > > > > PS: Don't know this is the second time I send the mail, b/c it
> > > > > > was not listed
> > > > > > @ lists.kde.org and I didn't become a mail back :-(


-------------- next part --------------
A non-text attachment was scrubbed...
Name: kgetnewdownloaddialog.diff
Type: text/x-diff
Size: 8147 bytes
Desc: not available
Url : http://mail.kde.org/pipermail/kget/attachments/20071002/ac1e2afa/attachment.bin 


More information about the Kget mailing list