D29526: Thumbnails: make thumbnail generation dpr-aware

Méven Car noreply at phabricator.kde.org
Wed May 13 16:05:50 BST 2020


meven added inline comments.

INLINE COMMENTS

> sitter wrote in thumbnail.cpp:774
> Var naming is a bit inconsistent across the code base now. In the implementations there are maxWidth/H that are device-adjusted but in here they are not. Not a huge concern, just noticed.

Will take care

> thumbnail.cpp:791
>      // for the same directory and sequence-item
>      qsrand(qHash(filePath));
>  

Not used can be removed.

> thumbnail.cpp:794
>      // Apply fake smooth scaling, as seen on several blogs
> -    if (subThumbnail.width() > width * 4 || subThumbnail.height() > height * 4) {
> -        subThumbnail = subThumbnail.scaled(width*4, height*4, Qt::KeepAspectRatio, Qt::FastTransformation);
> +    if (subThumbnail.width() > width * 4 * subThumbnail.devicePixelRatio() || subThumbnail.height() > height * 4 * subThumbnail.devicePixelRatio()) {
> +        subThumbnail = subThumbnail.scaled(width * 4 * subThumbnail.devicePixelRatio(), height * 4 * subThumbnail.devicePixelRatio(), Qt::KeepAspectRatio, Qt::FastTransformation);

Because of line above `scaleDownImage` can never happen.
Can probably be removed.

REPOSITORY
  R320 KIO Extras

REVISION DETAIL
  https://phabricator.kde.org/D29526

To: meven, #frameworks, dfaure, broulik, sitter, ngraham
Cc: kde-frameworks-devel, kfm-devel, waitquietly, azyx, nikolaik, pberestov, iasensio, aprcela, fprice, LeGast00n, cblack, fbampaloukas, alexde, Codezela, feverfew, meven, michaelh, spoorun, navarromorales, firef, ngraham, andrebarros, bruns, emmanuelp, rdieter, mikesomov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20200513/fa123845/attachment.htm>


More information about the kfm-devel mailing list