D28745: Skip caching thumbnails on encrypted filesystems
David Faure
noreply at phabricator.kde.org
Thu Aug 27 13:18:22 BST 2020
dfaure added inline comments.
INLINE COMMENTS
> thumbnail.cpp:741
> + bool allowCache;
> + allowCache = sharesFilesystemWithThumbRoot(filePath);
> + if (!allowCache) {
join with previous line (this isn't C) ;)
> thumbnail.h:95
> +#ifndef Q_OS_WIN
> + static const dev_t deviceIdUnset = std::numeric_limits<dev_t>::max();
> + dev_t m_thumbnailDirDeviceId = deviceIdUnset;
Suggestion: name it s_deviceIdUnset (s for static, to match m for member).
This makes things more readable when looking at the .cpp file (looks like a local variable otherwise).
REPOSITORY
R320 KIO Extras
REVISION DETAIL
https://phabricator.kde.org/D28745
To: marcingu, ivan, broulik, #dolphin, ngraham, meven, bruns, dfaure
Cc: dfaure, thiago, bruns, meven, ngraham, kde-frameworks-devel, kfm-devel, waitquietly, azyx, nikolaik, pberestov, iasensio, aprcela, fprice, LeGast00n, cblack, fbampaloukas, alexde, Codezela, feverfew, michaelh, spoorun, navarromorales, firef, andrebarros, emmanuelp, rdieter, mikesomov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20200827/0ff4ebc9/attachment.htm>
More information about the kfm-devel
mailing list