D25335: [Details mode] Allow to fill the column size of directories with actual size
Nathaniel Graham
noreply at phabricator.kde.org
Fri Apr 10 00:48:49 BST 2020
ngraham added inline comments.
INLINE COMMENTS
> kdirectorycontentscounterworker.h:40
>
> + struct CountResult{
> + /// nb of elements in the directory
whitespace
> kdirectorycontentscounterworker.h:41
> + struct CountResult{
> + /// nb of elements in the directory
> + int count;
"number" would be more readable than "nb"
> dolphin_detailsmodesettings.kcfg:49
> + <label>Recursive directory size limit</label>
> + <default>0</default>
> + </entry>
Given that the feature is off by default, let's set this at a more reasonable default level like 10, so that when you turn it on, it's instantly useful.
> viewsettingstab.cpp:123
> + m_recursiveDirectorySizeLimit = new QSpinBox();
> + m_recursiveDirectorySizeLimit->setSuffix(i18nc("spinbox:suffix Directory level recursion depth", " level(s) deep"));
> + m_recursiveDirectorySizeLimit->setRange(1, 20);
Use `i18ncp()` to handle plurals:
i18ncp("spinbox:suffix Directory level recursion depth", " level deep", " levels deep")
> viewsettingstab.cpp:184
> + DetailsModeSettings::setRecursiveDirectorySizeLimit(0);
> + }else{
> + DetailsModeSettings::setRecursiveDirectorySizeLimit(m_recursiveDirectorySizeLimit->value());
whitespace
REPOSITORY
R318 Dolphin
BRANCH
arcpatch-D25335_2
REVISION DETAIL
https://phabricator.kde.org/D25335
To: meven, elvisangelaccio, ngraham
Cc: anthonyfieroni, iasensio, kfm-devel, azyx, nikolaik, pberestov, fprice, fbampaloukas, alexde, Codezela, feverfew, meven, spoorun, navarromorales, firef, ngraham, andrebarros, emmanuelp, rdieter, mikesomov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20200409/e91aee60/attachment.htm>
More information about the kfm-devel
mailing list