D21157: handle maps with multiple or single entries from Baloo
Elvis Angelaccio
noreply at phabricator.kde.org
Sun May 19 10:41:04 BST 2019
elvisangelaccio added inline comments.
INLINE COMMENTS
> kbaloorolesprovider.cpp:62
> + const auto& propMap = file.properties();
> + auto begin = propMap.constKeyValueBegin();
> +
Maybe we could call this variable `rangeBegin` to be consistent with `rangeEnd` below?
> kbaloorolesprovider.cpp:66
> + auto key = (*begin).first;
> + const KFileMetaData::PropertyInfo pi(key);
> + const QByteArray role = roleForProperty(pi.name());
While at it, I'd rename this variable to `propertyInfo` to better explain its role.
REPOSITORY
R318 Dolphin
REVISION DETAIL
https://phabricator.kde.org/D21157
To: astippich, #dolphin, elvisangelaccio, bruns
Cc: kfm-devel, alexde, feverfew, meven, spoorun, navarromorales, firef, andrebarros, emmanuelp, mikesomov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20190519/9107f015/attachment.htm>
More information about the kfm-devel
mailing list