D18161: [kioslave/file] Add a codec for legacy filenames
David Faure
noreply at phabricator.kde.org
Fri May 17 20:19:48 BST 2019
dfaure accepted this revision.
dfaure added inline comments.
This revision is now accepted and ready to land.
INLINE COMMENTS
> legacycodec.cpp:118
> + bool nonCharacter;
> + if (!(nonCharacter = QChar::isNonCharacter(uc)) && uc > 0xffff && uc < 0x110000) {
> + // surrogate pair
[it would be so much more readable to move the assignment to the previous line...]
> legacycodec.h:21
> +#ifndef LEGACY_CODEC_H
> +#define LEGACY_CODEC_H 1
> +
this "1" here is unusual :-)
> legacycodec.h:36
> + setCodecForLocale(nullptr);
> + };
> +
remove the extra ';', some compilers warn about that.
REPOSITORY
R241 KIO
REVISION DETAIL
https://phabricator.kde.org/D18161
To: cfeck, #frameworks, #dolphin, dfaure
Cc: frispete, nathanshearer, nerdopolist, ngraham, kde-frameworks-devel, michaelh, bruns
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20190517/0b677a2d/attachment.htm>
More information about the kfm-devel
mailing list