D18945: New tab should be placed after the current tab

Nathaniel Graham noreply at phabricator.kde.org
Tue Feb 12 18:16:08 GMT 2019


ngraham requested changes to this revision.
ngraham added inline comments.
This revision now requires changes to proceed.

INLINE COMMENTS

> dolphintabwidget.h:112
>       */
> -    void openNewTab(const QUrl &primaryUrl, const QUrl &secondaryUrl = QUrl());
> +    void openNewTab(const QUrl &primaryUrl, const QUrl &secondaryUrl = QUrl(), bool afterCurrent = false);
>  

In general, using bools as arguments is not ideal since it's not very readable. Consider defining an Enum instead.

For further information see for example:

- http://flipcode.com/archives/Replacing_Bool_Arguments_With_Enums.shtml
- https://codereview.stackexchange.com/questions/11300/boolean-enums-improved-clarity-or-just-overkill

REPOSITORY
  R318 Dolphin

REVISION DETAIL
  https://phabricator.kde.org/D18945

To: hallas, #dolphin, ngraham
Cc: ngraham, kfm-devel, alexde, feverfew, spoorun, navarromorales, firef, andrebarros, emmanuelp, mikesomov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20190212/c070ff2c/attachment.htm>


More information about the kfm-devel mailing list