D20532: Proof of Concept: Add double click actions to empty space in the folder view

Nathaniel Graham noreply at phabricator.kde.org
Sun Aug 4 15:57:01 BST 2019


ngraham requested changes to this revision.
ngraham added a comment.
This revision now requires changes to proceed.


  Let's put this on the Navigation page. It's not a perfect fit, but I think makes sense to hide it there so it doesn't clutter up the General page. Also, //most// if the possible actions are navigation-related, and it's invoked by double-clicking in the view, which is a navigation area.
  
  We need a UI to expose that the `{path}` token gets replaced with the actual path. Maybe a label below the text field that appears when using a custom action?
  
  Finally, it feels quite slow. When I double-click, there's a noticeable delay before the action gets executed. Maybe this is because of all the scanning widgets to find the main window? That doesn't feel like the correct approach, just browsing the diff.
  
  Oh and one last thing: every action seems to have an ampersand at the beginning of its name: F7159477: Screenshot_20190804_085630.png <https://phabricator.kde.org/F7159477>

INLINE COMMENTS

> kitemlistcontroller.cpp:46
> +#include <QComboBox>
> +#include <QProcess>
> +

Put these new includes in the right places (e.g. Qt includes in the section with other Qt includes)

> kitemlistcontroller.cpp:808
> +    DolphinView *view = qobject_cast<DolphinView*>(parent()->parent());
> +    if(view == nullptr) {
> +        return;

coding style: space after the `if`

> kitemlistcontroller.h:307
>  
> +    void doubleClickEmptyView();
> +

I'd name this function `doubleClickViewBackground`

> behaviorsettingspage.h:32
> +class QComboBox;
> +class QLineEdit;
>  

When you add new includes, maintain alphabetical ordering

REPOSITORY
  R318 Dolphin

REVISION DETAIL
  https://phabricator.kde.org/D20532

To: fbg13, #dolphin, elvisangelaccio, #vdg, ngraham
Cc: kneckermcknacksack, ngraham, kfm-devel, aprcela, vmarinescu, fprice, fbampaloukas, alexde, feverfew, meven, spoorun, navarromorales, firef, andrebarros, emmanuelp, mikesomov
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20190804/f6f384fe/attachment.htm>


More information about the kfm-devel mailing list