D6281: Prevent folders from drag and dropping onto themselves in dolphin main view

David Faure noreply at phabricator.kde.org
Sun Nov 5 21:47:44 GMT 2017


dfaure requested changes to this revision.
dfaure added inline comments.
This revision now requires changes to proceed.

INLINE COMMENTS

> kitemmodelbase.cpp:16


one space between return and QUrl was enough, no need to have two.

> elvisangelaccio wrote in kitemmodelbase.h:188
> How about calling it just `getUrl(int index)`?

In Qt/KDE code, for non-static methods, getFoo() is actually not the convention, foo() is.
I would have named this url(int), unless this would clash with another url() method.

> elvisangelaccio wrote in draganddrophelper.cpp:35
> We can use the C++11 `for` loop here (`foreach` will be eventually deprecated).

I would have used std::find_if, actually, but OK ;-)

(at least, `const auto &` would be the more usual way to write this)

REVISION DETAIL
  https://phabricator.kde.org/D6281

To: emateli, #dolphin, elvisangelaccio, ngraham, rkflx, dfaure
Cc: rkflx, ngraham, elvisangelaccio, dfaure, anthonyfieroni, #konqueror, spoorun, navarromorales, firef, andrebarros, emmanuelp
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20171105/082ab5dc/attachment.htm>


More information about the kfm-devel mailing list