Review Request 125651: Dolphin-plugins svn commit action

Emmanuel Pescosta emmanuelpescosta099 at gmail.com
Thu Oct 22 13:52:03 BST 2015


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/125651/#review87261
-----------------------------------------------------------



svn/fileviewsvnplugin.cpp (lines 443 - 444)
<https://git.reviewboard.kde.org/r/125651/#comment59938>

    I would prefer:
    for (auto it = m_versionInfoHash.cbegin(); it != m_versionInfoHash.cend(); ++it) {
        ...
    }
    
    but this is just my personal preference ;)



svn/fileviewsvnplugin.cpp (lines 443 - 456)
<https://git.reviewboard.kde.org/r/125651/#comment59941>

    Please put this into a new method and return the version state of the directory. 
    
    This method can then also replace the duplicated code in FileViewSvnPlugin::itemVersion (itemVersion will then show conflicts for directories as well :))
    
    You can then use the version to enable/disable the actions, e.g.:
    
    version = directoryVersion(directory);
    commit.enabled = enabled && (version == modified);



svn/fileviewsvnplugin.cpp (line 445)
<https://git.reviewboard.kde.org/r/125651/#comment59939>

    Ugh! This is something which should be fixed in the svn plugin in future, either by adding the directories to the info hash or by using a suitable data structure. (but this has to be fixed in the whole file, so you can leave it as it is for now ;)



svn/fileviewsvnplugin.cpp (line 446)
<https://git.reviewboard.kde.org/r/125651/#comment59940>

    m_versionInfoHash.value(it.key()) -> it.value()


- Emmanuel Pescosta


On Oct. 16, 2015, 6:42 a.m., Anthony Fieroni wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/125651/
> -----------------------------------------------------------
> 
> (Updated Oct. 16, 2015, 6:42 a.m.)
> 
> 
> Review request for Dolphin.
> 
> 
> Repository: dolphin-plugins
> 
> 
> Description
> -------
> 
> Do not enable commit action permanently
> 
> 
> Diffs
> -----
> 
>   svn/fileviewsvnplugin.cpp a7f92bb 
> 
> Diff: https://git.reviewboard.kde.org/r/125651/diff/
> 
> 
> Testing
> -------
> 
> Enable commit on modified non confict items, enable show differences on modified or conflict items
> 
> 
> Thanks,
> 
> Anthony Fieroni
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20151022/ca5eef7b/attachment.htm>


More information about the kfm-devel mailing list